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INTRODUCTION
The Internet In A Box applications allow you to access the Internet with
ease.  Designed with the look and feel of other Windows applications,
Internet In A Box applications provide an intuitive interface to the Inter-
net, eliminating the need to learn complex commands.  You can easily
customize your Internet In A Box sessions with Mosaic hotlists, News
personal groups, NFM Connections, and more, allowing you easy, quick
access to the resources you use most frequently.

This Guide describes how to use the applications in Internet In A Box.  All
of the applications in Internet In A Box are documented in this Guide,
except for the Dialer, which is documented in the Installation & Configura-
tion Guide, and the UUCode and ImageView utilities; see the online help
for information on using UUCode and ImageView.

All of the Internet In A Box  applications feature on-line help.  Be sure to
check the on-line help for the most up to date information about the
applications.
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DOCUMENTATION SYMBOLS
Throughout this Guide, the following symbols are used to denote notes,
hints, and warnings:

Note.  Something to bear in mind when performing the described step or
task.

Technical Note.  Information you don’t need to know, but might be curious
about.

Hint.  Shortcuts or suggestions.

Warning.  Something to watch out for or avoid!
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INTRODUCTION
Mosaic is a browser program that enables you to access the Internet World
Wide Web.

The World Wide Web provides a variety of rich multimedia information in
a graphical, easy-to-use format. When people talk about the World Wide
Web, they are principally referring to HTML documents located on
Internet servers around the world. These documents, referred to as Web
pages, include text, images, and multimedia files, as well as hyperlinks that
jump to other Web pages and Internet sites. In addition to Web pages, the
World Wide Web also includes ftp sites, gopher sites, news servers, and
more.

Mosaic is designed to make it easy for you to browse the World Wide Web,
and make the most out of the information you find there.

FEATURES
· Read information, view pictures and video, and play sounds and

music.

· Organize favorite Web pages into hotlists that contain your favorite
Web pages, including folders and subfolders, and add selected
hotlists to your Mosaic menu.

· Access previously viewed Web pages.

· Read and post news, send e-mail, and access ftp and gopher sites.

· Drag and drop Web pages and images to other applications.

· View inline GIF and JPEG graphics.

ABOUT THIS GUIDE

This User Guide is designed to teach you how to use Mosaic to browse the
World Wide Web, print and save Mosaic information, organize Web pages,
access ftp, gopher, news and Mail, and more. For information on specific
Mosaic commands and dialog boxes, refer to Mosaic’s comprehensive
online help, available in the Help menu.

If you are using Windows 95, you can take advantage of Mosaic’s new
context sensitive online help. You can get help with any item in a dialog
box by clicking the  button at the top of a dialog box, and then click an
item you want information about. You can also click dialog items with
your right mouse button to get information.
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THE MOSAIC WINDOW
The Mosaic window is used to display Web pages, which often contain
hyperlinks that you can click on to jump to another Web page. Some
hyperlinks allow you to download a file or perform another action (such as
sending an e-mail message).

Hyperlinks are often indicated by colored or underlined text, or in the case
of images, by a colored border (the default color is blue). You know you are
on a hyperlink when your cursor changes to a pointing hand:

The toolbar at the top of the window contains buttons that serve as
shortcuts for Mosaic menu items.

The Web Page box, found underneath the toolbar, contains a list of Web
pages you have recently accessed.

You can select a Web page from the drop down list to immediately load
that page, or type a URL (Web page address) for a Web page in this box
and press ENTER to access that page.

Many URLs take the form http://www.name.com; you can quickly access
those URLs by typing name; for instance, typing paramount takes you to
http://www.paramount.com.
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The Mosaic logo, found to the right of the Web Page box, moves to
indicate that an action (such as loading a Web page or image, or down-
loading a file) is in progress.

Both the toolbar and the Web Page box can be shown or hidden by
checking or unchecking Toolbar and Web Page Bar in the View menu.
The toolbar style can be changed by changing the options in the Display
tab of the View Options dialog box.

The status bar at the bottom of the Mosaic window displays the progress of
various actions. When you place your cursor on a hyperlink, it displays the
URL for that hyperlink.
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MOSAIC’S SHORTCUT MENUS
Mosaic includes two special menus that you can access using your right
mouse button.

THE HYPERLINK MENU
The Hyperlink menu appears when you click the right mouse button on a
hyperlink. The menu items vary depending on the type of hyperlink you
have highlighted. The Hyperlink menu options are listed below.

Opens the selected item.
Saves the selected item to disk.
Displays information about the selected item.
Copies the selected item’s URL to the Windows clipboard.
Opens the selected image in an external program.
Saves the selected image to disk.
Displays information about the selected image.
Copies the selected image’s URL to the Windows clipboard.
Creates a Windows 95 shortcut for the currently selected URL. This
option is only available in Windows 95.

THE QUICK MENU
The Quick menu appears when you click the right mouse button anywhere
in a Web page except on a hyperlink. The first three menu options, Back,
Forward, and Add to Hotlist, are equivalent to the Mosaic toolbar buttons
Backward, Forward, and Add. The Quick menu options are listed below.

Returns to the Web page that was loaded before the current page.

Moves to the Web page that you viewed after the current page.

Adds the currently displayed Web page to your current Mosaic hotlist.

Copies the URL of the current Web page to the Windows clipboard.

Creates a Windows 95 shortcut for the current Web page. This option is
only available in Windows 95.

Mosaic’s shortcut menus
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UNDERSTANDING URLS
A URL (Uniform Resource Locator) specifies the address, or location, of a
resource on the Internet. Mosaic uses URLs to access many different types
of resources, including ftp sites, telnet sites, gopher sites, and more. To
access a resource, type the resource’s URL in the Web Page box and press
ENTER.

To access: Type:

A Web page http://hostname/pathname

where hostname is the IP address of the Web page, and
pathname (optional) describes the exact pathname of the page.

Examples:

http://www.federation.gov/Enterprise

http://www.bakerstreet.com/cases.html

http://165.121.6.240

An anonymous ftp server ftp://hostname

where hostname is the IP address of the ftp site.

Examples:

ftp://ftp.circe.com

ftp://165.121.6.45

A local HTML file file:///pathname

where pathname indicates the full path of the HTML file.

Examples:

file:///c:\html\mypage.htm

file:///f:\tech\tequila.htm

A telnet server telnet://hostname

where hostname is the IP address of the telnet site. You can add a
port by adding a colon followed by the port number (for
example, :23).

Examples:

telnet://odysseus.circe.com

telnet://165.121.6.220

telnet://165.121.6.6:23

A gopher server gopher://hostname

where hostname is the IP address of the telnet site. Port informa-
tion can be provided by adding a colon followed by the port
number (for example, :70).

Examples:

gopher://gopher.narnia.com

gopher://gopher.gardenia.com

gopher://gopher.louvre.com:70/art
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A USENET newsgroup news:newsgroupname

where newsgroupname is the name of the newsgroup you want
to access.

Example:

news:alt.tv.seinfeld

See “Using ftp, gopher, news, and e-mail” for more detailed information on
using URLs to access ftp, gopher, news, and mail resources.
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BROWSING WEB PAGES
When you open a Web page in Mosaic, you see the text on that page, and
any images on that page are loaded, top to bottom. You can control how
images are loaded onto the page by changing the Images options in the
Display tab of the View Options dialog box.

To stop loading the current page, click Stop Transfer on the Navigate menu
(or click the Stop button on the Mosaic toolbar).

If a page does not load properly—for instance, all of the images on the
page do not appear or the connection to the server “times out”—you can
click Reload on the Navigate menu (or click the Reload button on the
toolbar) to try to load the page again.

MOVING TO ANOTHER WEB PAGE

There are several ways to move to another Web page in Mosaic.

Click To

A hyperlink Jump to the Web page referenced by the hyperlink.

The Backward and Forward Move to the Web pages you accessed before and after
buttons on the toolbar the current page. (You can also type the B and F keys

on your keyboard.)

 

The Home button on the toolbar Access the startup Home page for Mosaic (defined in
the Pages tab of the View Options dialog box.)

You can also type a URL (address) in the Web Page box (under the Mosaic
toolbar)  to access a Web page; type the URL for a Web page, or choose
from a list of the Web pages you have recently visited.  The History option
(in the Navigate menu) will allow you to access a list of the Web pages you
have visited this session and access any of those Web pages.
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OPENING A WEB PAGE USING A URL
You can specify a Web page to open by supplying the URL (address) for
that page. Most Web pages that you will encounter are HTML pages,
which reside on HTTP sites. This type of URL is preceded by http://
followed by the address and pathname of the HTML page, as in http://
www.bakerstreet.com/221B.html.

For more information on URLs, see “Understanding URLs” earlier in this
guide.

TO OPEN A WEB PAGE USING A URL:

1. Type a URL in the Web Page box found below the Mosaic toolbar.

2. Press ENTER.

You can paste a URL that you have copied from another program
into this box. With your cursor in the box, press CTRL+V.

OPENING A LOCAL FILE

You can open HTML files that are stored on your local system. You might
do this to view a Web page without connecting to the Internet. You can
easily save Web pages to a file; for more information on saving Web pages,
see “Saving Web pages, files, and images” later in this guide.

Local Web pages usually have a file extension of .HTM.

TO OPEN A LOCAL WEB PAGE:

1. Click Open Local File on the File menu.

2. Locate the local Web page file.
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WORKING WITH MOSAIC INFORMATION
You can copy, paste, save, and print the information you see in Web pages,
as described in the sections that follow.

COPYING AND PASTING INFORMATION

Like other Windows programs, Mosaic includes full support for the
Windows clipboard. You can paste information from another program into
Mosaic, or copy information from Mosaic to other programs. For example,
you can copy a URL from a mail message or news article and paste it into
the Web Page box in order to quickly access that URL.

You can only copy and paste in areas in Mosaic where you can also type.

To Do this

Copy information from Mosaic Select the information, and press CTRL+C.

Copy a URL from a Web page Move your cursor over the URL’s hyperlink, click the
right mouse button, and click Copy URL from the
Hyperlink menu.

Paste information into Mosaic Place your cursor at the location where you want to
paste the information, and press CTRL+V.

SAVING WEB PAGES, FILES, AND IMAGES

There are several different ways to save items in Mosaic:

· Use Mosaic’s Hyperlink menu.

Click a hyperlink for an item you want to save with the right mouse
button and select either Save to Disk or Save Image to Disk from the
Hyperlink menu.

· Use Load to Disk mode.

You can turn on Load to Disk mode to save each graphic or
hyperlink that you click on, without loading it. Click Load to Disk
Mode on the View menu (a check mark indicates that the mode is
enabled). When Load to Disk Mode is enabled, each time you try to
access an item you are prompted for a name and location to save the
item. Note that items that you access are not be loaded or displayed;
they are only saved.

Mosaic continues to try to save items until you disable Load to Disk
Mode by selecting the Load to Disk Mode option again. If you want
to use Load to Disk Mode selectively, you can temporarily enable it
by holding down the SHIFT key while you click an item.
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PRINTING A WEB PAGE

You can print the Web page you are currently viewing to a printer. If you
want to see how the output will look when you print, click Print Preview
on the File menu.

TO PRINT A WEB PAGE:

■ Click Print on the File menu. You can click the Setup button in the
Print dialog box to specify a different printer or set up options for
printing.

TO CHANGE THE PRINT MARGINS:

■ Click Print Margins on the File menu to adjust the margins of the
printed document.
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WORKING WITH HOTLISTS
You can store your favorite Web pages in a hotlist so that you can easily
access those pages again. You might use hotlists to group Web pages by
category, such as subject (Games, Sports, Weather, Work) or user (Joe’s
hotlist, Ryan’s hotlist, Greg’s hotlist). Individual hotlists can contain folders
and subfolders to further organize your information.

Hotlists are stored in hotlist files (usually with the extension .HOT), which
makes it easy for you to give your hotlists to other Mosaic users.

You can access hotlists from the Hotlists dialog box, or add them to
Mosaic’s menu bar for quick access.

ACCESSING A WEB PAGE USING A HOTLIST

You can use a hotlist to quickly access your favorite Web pages. Mosaic
includes pre-defined hotlists to get you started.

TO ACCESS A WEB PAGE USING A HOTLIST:

1. Click Hotlists on the File menu. The Hotlists dialog box will appear,
displaying your Mosaic hotlists.

A hotlist is displayed as the  icon. Above, Business, Computer
Information, and Hobbies are all separate hotlists, which contain Web
pages and subfolders.

2. Open the hotlist that contains the page you want to access by double-
clicking the hotlist icon. You can double-click a folder icon in the hotlist
to see the items in that folder.

3. Double-click the Web page you want to display.
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CREATING A NEW HOTLIST

You can create a new hotlist so that you can organize your favorite Web
page addresses for fast access.

TO CREATE A NEW HOTLIST:

1. Click Hotlists on the File menu. The Hotlists dialog box will appear,
displaying your Mosaic hotlists.

2. Click the Open/New button.

3. Specify a filename and directory for your new hotlist (the extension
.HOT is suggested).

4. Type a name for the hotlist. The name can be any length you want, but
you may want to keep it short in case you add the hotlist to Mosaic’s
menu bar.

You can convert NCSA Mosaic menus to hotlists using the Import
NCSA Menu as Hotlist command on the Options menu.

OPENING A HOTLIST

You can open an existing hotlist file and add it to the Hotlists dialog box.
This is useful if you receive a hotlist from someone else and want to add it
to Mosaic, or want to add a hotlist that you previously removed from the
Hotlists dialog box.

TO OPEN A HOTLIST:

1. Click Hotlists on the File menu.

2. Click the Open/New button. The Open/Create New Hotlist dialog box
will appear.

3. Specify the hotlist file name.
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ADDING A HOTLIST TO THE MOSAIC MENU

You can use any hotlist as a Mosaic menu, with all the hotlist items
appearing as items on the menu. Folders within the hotlist will appear as
menu items, and the folder contents will appear as sub-menu items.

TO ADD A HOTLIST TO THE MOSAIC MENU:

1. Click Hotlists on the File menu.

2. Select the hotlist you want to add to the Mosaic menu.

3. Check the Add to Menu box. The hotlist icon  changes to the
following icon:

and the hotlist is added to the menu.

ADDING A WEB PAGE TO A HOTLIST

You can easily add a Web page to one of your hotlists.

TO ADD A WEB PAGE TO THE END OF THE CURRENT HOTLIST:

■ If you are currently viewing the Web page you want to add to a hotlist,
you can click Add Web Page to Hotlist on the Navigate menu to add the
document to the end of the current hotlist (the last hotlist you opened).

TO ADD A WEB PAGE TO A HOTLIST:

1. Click Hotlists on the File menu.

2. Select the hotlist to which you want to add the Web page.

3. Select the place in the hotlist where you want to place the Web page.
The new Web page is added above the item you select.

For instance, to insert the Web page “Cooking with Oregano” in
between “Badminton tips” and “Wide World of Webcrawling,” you
would highlight “Wide World of Webcrawling” before inserting the new
Web page.

4. Click the Insert button.

5. Click Web Page in the Insert New dialog box.
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6. Fill out the next dialog box with information about the Web page. If
you are currently viewing a Web page, this dialog box is filled out for
you.

In the Title box, type the name you would like to use for this Web page
in your hotlist. Spaces are permitted.

In the URL box, type the URL for the Web page. You can copy and
paste a URL into this dialog box, if you choose.

You can also drag and drop a hyperlink into a hotlist or hotlist
folder.

ADDING FOLDERS TO A HOTLIST

You may want to use hotlist folders to help organize your information. You
can place a folder anywhere in a hotlist, even inside another folder.

TO ADD A FOLDER TO A HOTLIST:

1. Select the hotlist to which you want to add the folder.

2. Select the place in the hotlist where you want to add the folder. The new
folder will be added above the item you select.

For instance, to insert a “Humor” folder between a “Hobbies” folder and
a “Lists of Sites” folder, you would highlight “Lists of Sites” before
inserting the new Web folder.

3. Click the Insert button.

4. Click Folder in the Insert New dialog box.

5. Specify a name for the new folder.

EXPORTING A HOTLIST

You can export any of your hotlists as an HTML file. You might do this to
give the hotlist information to someone who doesn’t have Mosaic. You can
also use the hotlist as your default Home page.

TO EXPORT A HOTLIST:

1. Click Hotlists on the File menu.

2. Click the Export button.

3. Type a filename for the hotlist; the extension .HTM is suggested.
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After you export the file, you can open it by clicking Open Local File on
the File menu. The file is displayed as a Web page containing a list of
hyperlinks that jump to the Web pages in your hotlist.
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SEARCHING THE WORLD WIDE WEB
The default Mosaic hotlists and startup Home page contain many useful
links that help you get started using the World Wide Web.

You can click the Search button on the toolbar, or click Search Internet on
the Edit menu to quickly launch a Web page you can use to search the
World Wide Web. By default, this page is the Internet Wizard, an easy-to-
use search tool that uses keywords to search for information. You can
change the search page that is loaded by changing the Search Page option
in the Pages tab of the View Options dialog box (choose Options from the
View menu).

There are many Web pages on the Internet that enable you to search for
specific information or browse indexed lists of information. Some popular
and useful sites are listed below. You can access these Web pages by typing
the URL in the Web Page box under the toolbar, and pressing ENTER.

Web page URL (address)

Yahoo! http://www.yahoo.com

InfoSeek NetSearch http://www2.infoseek.com

WebCrawler http://webcrawler.com

World Wide Web Worm http://www.cs.colorado.edu/home/mcbryan/WWWW.html

Web Servers http://www.w3.org/hypertext/DataSources/WWW/
Servers.html

Whole Internet Catalog http://nearnet.gnn.com/wic/index.html

Archieplex http://web.nexor.co.uk/public/archie/archieplex/
archieplex.html
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FINDING TEXT ON A WEB PAGE
You can search a Web page for particular text.

TO FIND TEXT ON A WEB PAGE:

1. Click Find on the Edit menu.

2. Type the text you want to search for in the Find What: box. If you wish
to search only for words that match the capitalization of the specified
text, check the Match Case box.

3. Click the Find Next button.

The search starts at the top of the current screen and moves to the
bottom. If the search word is found, the line of text containing the word
appears at the top of the screen.  Note that the word will not be high-
lighted.

4. Click the Find Next button to find the next occurrence of the word.

-OR-

Click Cancel to close the dialog box.
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USING FTP, GOPHER, NEWS, AND E-MAIL
Mosaic not only lets you view HTML pages specifically designed for the
World Wide Web, but enables you to access other Internet resources such
as ftp and gopher sites. You can also use Mosaic to access USENET news
and send e-mail. Note that Mosaic is primarily designed for browsing the
World Wide Web; for more full-featured use of ftp, gopher, news, and e-
mail, more sophisticated programs may be more appropriate.

OVERVIEW OF FTP
File transfer protocol, or ftp, is used to send and receive files across net-
works. Mosaic allows you to use ftp to obtain files from the Internet.
Anonymous ftp sites on the Internet contain countless freeware and
shareware files that you can transfer to your PC.

Due to the popularity of ftp sites, there may be restrictions, such as limited
hours for ftp access or limits to the number of users that can access a site at
once.

OVERVIEW OF GOPHER
Gopher sites display collections of information organized by subject. You
can access many different types of resources using gopher, including
images, sounds, and searchable databases. You may need additional pro-
grams to view some of the items you find using gopher.

OVERVIEW OF NEWS
USENET news is a forum for discussion (similar to a bulletin board
system, but on a much larger scale) that is found on the Internet. You can
read news articles about specific topics and contribute to the discussions by
posting (adding) your own articles.

Mosaic enables you to access news using Mosaic’s built-in news function or
the SPRY News program. If you have SPRY News on your system, Mosaic
automatically launches it when you access a newsgroup or news article. If
you do not have SPRY news, or prefer to use Mosaic’s built-in news
function, check the Use Built-in Mail and News box in the Services tab of
the Tools Options dialog box.
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In order to read news using Mosaic, you will need to have access to a news
server.  Mosaic is set up with a news server address you can use, but you
may have limited access to this news server.  Contact your system adminis-
trator or Internet service provider for more information about what news
server you should use.

You should set up the news server address in Mosaic by typing it in the
news server box in the Services tab of the Tools Options dialog box.

OVERVIEW OF E-MAIL
E-mail is a method used to send messages to other people.  On some
Mosaic Web pages, you may see hyperlinks that you can click on to send
mail to a Web page author.  Although Mosaic can be used to send mail,
you cannot receive mail using Mosaic. If you want to receive mail, you
need a dedicated mail program such as SPRY Mail and an account on a
mail server.

Mosaic enables you to send mail using either Mosaic’s built-in mail
function or the SPRY Mail program. If you have SPRY Mail on your
system, Mosaic automatically launches SPRY Mail whenever you try to
send a mail message. If you do not have SPRY Mail, or you prefer to use
Mosaic’s built-in mail function, check the Use Built-in Mail and News
box in the Services tab of the Tools Options dialog box.

In order to send mail using the built-in mail send feature, you need to
specify an SMTP Server address in the Services tab of the Tools Options
dialog box.  A default server address is provided for you.
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ACCESSING FTP SITES

You can access ftp sites and download files using Mosaic.

TO ACCESS AN FTP SITE:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the URL for the ftp site you want to connect to:

ftp://hostname

where hostname is the IP address of the ftp site.

For example: ftp://ftp.narnia.com, or ftp://165.121.6.26.

If you’re connecting to an ftp site which requires a username and
password, you can also type

ftp://username:password@hostname

where username and password are your username and password on the
ftp site.

For example, ftp://lucy:aslan@ftp.narnia.com.

The ftp site is displayed as a list of files and folders. You can double-click
a folder to open it and display its contents. A hyperlink at the top of the
file (usually called Up to Parent Directory) takes you back to the previ-
ous level.

TO DOWNLOAD A FILE:

■ When you see a file you want to access, click the filename. Text files will
be displayed in the Mosaic window. If you set up a program for the file
(using the File Types option found in the Tools Options dialog box), the
file is opened using the program. Otherwise, you are asked whether to
save the file to disk.
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For more information on specifying programs to use for specific file
types, see “Setting up file types” later in this guide.

ACCESSING GOPHER SITES

You can access a gopher site using Mosaic.

TO ACCESS A GOPHER SITE:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the URL for the gopher site you want to connect to:

gopher://hostname

 where hostname is the IP address of the gopher site.

For example, gopher://gopher.narnia.com, or gopher://165.121.6.45.

The gopher site appears as a list of different types of items.

TO ACCESS A GOPHER ITEM:

■ When you see an item you want to access, double-click it. If the item is a
text file, Mosaic displays it in the Mosaic window. If the item is a telnet,
TN3270, or Rlogin site, Mosaic opens it using the tool set up in the
Services tab of the Tools Options dialog box. If the item is a search tool,
Mosaic allows you to search the indicated database.

For other items, if you have set up a program for that file (using the File
Types option found in the Tools Options dialog box), the file will be
opened using that program. Otherwise, you are asked if you want to save
the file to disk.

For more information on specifying programs to use for specific file types,
see “Setting up file types” later in this guide.
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READING NEWS

You can read news on a news server using Mosaic. You may find links to
newsgroups on the World Wide Web, or you may want to connect to a
newsgroup directly, as described below.

TO ACCESS NEWS:

1. Click on a hyperlink that points to a newsgroup or news article.

-OR-

Place your cursor in the Web Page box beneath the toolbar and enter the
appropriate URL, as described below:

To Type

Access a specific newsgroup news:newsgroupname

where newsgroupname is the full name of the newsgroup
you want to access.

Example: news:alt.smurfs.

List all newsgroups news:*

List a range of newsgroups news:category.*

where category is the part of the newsgroup name that you
know, and * signifies all newsgroups within that category.

For example, news:alt.tv.* would display alt.tv.simpsons,
alt.tv.90210, etc., news:alt.* would display all the news-
groups with the prefix alt, and news:comp.* would display
all the newsgroups with the prefix comp.

2. If you are viewing a list of newsgroups, you can double-click any
newsgroup to display the articles in that newsgroup. A list of news
articles will appear.
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Mosaic displays news articles as bulleted items on the screen, grouped by
threads (topics). Articles posted in response to an original article are
indented below that article and are identified using the author’s name,
rather than an article subject.

By default, Mosaic displays descriptions of all the newsgroups; to
disable this feature, clear the Extended News Listing box in the
Services tab of the Tools Options dialog box. Note that
unchecking this option disables threading in news (described
below).

3. To view an article, simply click its title in the article list.

Mosaic displays hyperlinks at the top of the screen that you can click to
navigate through threads. When you are viewing an article that is part of
a thread, you will see either Next thread or Next article in thread and
Previous article in thread, depending on where you are in the thread.

POSTING NEWS
You can use Mosaic to post a news article to a newsgroup, as described
below. Note that some news servers and newsgroups do not allow you to
post articles.

TO POST A NEWS ARTICLE FROM THE NEWSGROUP SCREEN:

1. Make sure the newsgroup you want to post to is displayed on the screen,
with the articles in that newsgroup listed.

2. Click the Post to newsgroup hyperlink at the top of the screen, or, if
you want to follow up the article (responding to the article thread, and
including the text of the article), click the Followup to message
hyperlink.

3. Fill out the Post news dialog box with information about your article.
The Sender box may be filled out for you. Be sure to specify a Subject
for your article and complete the Sender box.

4. Type your article in the space provided. All the standard Windows edit
keys are supported; for instance, you can click CTRL-V to paste text
from other programs into your article.

Mosaic’s news feature does not automatically wrap words down to
the next line when you reach the end of a line. You will need to
press ENTER at the end of each line of your message so that your
message is displayed properly when it is received.
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TO POST A NEWS ARTICLE USING A URL:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the following URL:

newspost:newsgroupname[,newsgroupname,newsgroupname]
[/followup]

where newsgroupname is the name of the newsgroup where you want to
post your message.  You can specify multiple newsgroups by separating
them by commas; do not use spaces between the commas.

/followup is optional, and specifies that you want the posting to be a
follow-up posting. If an article is currently displayed, the followup post
will contain the text of the original article.

Examples

newspost:alt.tv.seinfeld

newspost:rec.bicycles,rec.sports.cycling

newspost:alt.suburbia/followup

SENDING E-MAIL

You can send e-mail messages using Mosaic. You may find hyperlinks that
will send an e-mail message to the address indicated in the hyperlink text.
You can also send e-mail as indicated below.

TO SEND MAIL FROM MOSAIC:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the following URL

mailto:address

where address is the e-mail address you want to send mail to.

For example, mailto:lucy@narnia.com.

3. Fill out the Send Mail dialog box with information about your message.
Be sure to specify a Recipient and a Subject for your message.

4. Type your mail message in the space provided. All the standard Win-
dows edit keys are supported, including CTRL-V to paste text from
other programs into your message.
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Mosaic’s Mail feature does not automatically wrap words down to
the next line when you reach the end of a line. You need to press
ENTER at the end of each line of your message so that your
message will be displayed properly.
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IMPROVING MOSAIC’S PERFORMANCE
There are several ways you can improve Mosaic’s performance:

· Increase system memory.

As with any Windows program, Mosaic’s performance improves if
you have more available system memory. If you often load in large
images or download large files, you should optimize your memory.

Using extended (not expanded) memory and a large Windows
swapfile (at least twice as large as your physical RAM; for example,
for 4 MB RAM, have a 8MB swapfile) may improve your perfor-
mance. See your DOS and Windows documentation for additional
information on increasing memory.

· Turn off inline images.

If you have a slow connection, or if you do not need to see images,
you can turn off the display of images by clearing the Automatically
Load Images option in the Display tab of the View Options dialog
box. If you turn off this option, image placeholders load instead of
the images, and Web pages load substantially faster. You can still
selectively load in images by clicking the images with your right
mouse button and selecting Load Image from the Hyperlink menu.

Note that many images are used as hyperlinks to other Web pages, so
disabling this option may make it more difficult to navigate the
Web. Many, but not all, Web pages display alternate methods for
accessing images.

· Change how often Mosaic loads images.

If you have a slow Internet connection, you may want to change
how often Mosaic loads images. Mosaic redraws the screen at the
interval you specify using the Image Update Frequency in the
Display tab of the View Options dialog box.

· Change how fast Mosaic loads images.

Normally, Mosaic loads and displays images with the highest quality
possible. You can choose to have Mosaic load images faster, sacrific-
ing some degree of quality, by changing the Image Display option in
the Display tab of the View Options dialog box to be Fastest Speed.

· Change the caching value.

Mosaic has a number of caching options, which can be configured
using the Cache options in the Advanced tab of the Tools Options
dialog box.

Mosaic uses caching to store retrieved information on your computer
in order to improve performance. When you next access the same



1-28 Improving Mosaic’s Performance

information, Mosaic accesses that information from the cache
instead of from the Internet. If you frequently access the same Web
pages, caching speeds up access to those pages.

Mosaic uses a combination of memory and disk caching to store
Web page information. Memory caching uses available RAM to
store information and is very fast. Disk caching creates files on your
system (using a permanent amount of disk space); it is not as fast as
memory caching, but is faster than retrieving a page from the
Internet.

· Create a local startup Home page.

If your startup Home page does not change often, you may want to
save the page to a local HTML file, so that you can access it more
quickly. Then, specify the name of that file in the Home Page box in
the Pages tab of the View Options dialog box.

CHANGING THE SCREEN APPEARANCE

There are several ways to change the appearance of the Mosaic window:

· Change the fonts used for text in the Mosaic window.

Text elements on a Web page have different styles associated with
them (defined by the Web page author). You can change the font
types and sizes that are used for these styles using the Fonts tab in
the View Options dialog box, selecting the style you want to change,
and clicking the Change Font button. You can also choose to enlarge
or reduce all the fonts using this dialog box. Note that changes in
this dialog box affect all Mosaic sessions.

· Change the appearance of the Mosaic hyperlinks.

You can change the color and underlining of Mosaic hyperlinks
using the Link Color and Visited Link Color options in the Display
tab in the View Options dialog box.

· Change the toolbar appearance.

The toolbar style can be changed between picture and text, picture
only, and text only by changing the Toolbar Style option in the
Display tab of the View Options dialog box.

· Display or hide the toolbar and Web Page bar.

You can hide the toolbar and Web Page bar (located beneath the
toolbar) by unchecking the Toolbar and Web Page Bar options in the
View menu.
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SETTING UP FILE TYPES

Mosaic can display text, GIF and JPEG graphics, and can play AU and
AIFF sound files. Other types of files, however, such as MPEG movie files,
require you to use additional programs in order to display them.

You can specify which program Mosaic will use to open a certain type of
file using file types.

TO CONFIGURE A FILE TYPE:

1. Click Options on the Tools menu.

2. Select the File Types tab in the Tools Options dialog box.

3. In the MIME Type box, select the MIME type of the item for which
you want to set up a program. You may have to set up a new MIME
type, if the MIME type you want is not listed. You should try to use the
same MIME type that is used on the World Wide Web server you are
accessing.

4. In the Extensions box, type any file extensions (such as .MPG, .AVI, or
.DOC) you want to use for the specified MIME type. If you are provid-
ing several extensions, separate the extensions with commas. Note that
UNIX servers sometime have case-sensitive filenames; you may want to
use both upper and lower cases for the extension (for example,
.mpg,.MPG,.mpeg).

Since MIME types, not file extensions, are used when accessing items on
an HTTP server, you only have to supply file extensions if you want to
be able to access items on ftp or gopher sites using the program you
specify.

5. In the Program box, type the full path and filename of the program you
want to use for the specified MIME type. If you are not sure of the
location of the program, click the Browse button.
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SETTING UP MIME TYPES

Mosaic uses MIME types to decide how to treat items you try to access on
an HTML Web page. For instance, MPEG movie files have MIME type
video/mpeg, and TIFF graphics have type application/tiff. You can find out
the MIME type of an item by clicking it with the right mouse button and
choosing Get Information (or Get Image Information) from the Hyperlink
menu that appears.

You may need to add new MIME types in order to set up programs
properly in Mosaic (using the File Types tab in the Tools Options dialog
box). Make sure you specify the MIME type correctly, because that is what
Mosaic uses to recognize the item so that it can start a program.

TO ADD A MIME TYPE:

1. Click Options on the Tools menu.

2. Select the File Types tab in the Tools Options dialog box.

3. Click the New button.

4. Type a name for the new MIME type.

5. Click OK to add the new MIME type. The new MIME type will be
added to the Type: list, and you can now set up programs for that
MIME type to that MIME type.

Mosaic uses extensions, not MIME types, to recognize items on ftp
sites. In order to set up file types for items on an ftp site, you will
still need to set up a MIME type, however. The name for this
MIME type can be anything you like, because the MIME type is
not really used by Mosaic to determine which program to use to
open the item. For example, if you wanted to set up a MIME type
so that you could open Visio files, you might create a new MIME
type called application/x-visio. You can then set up that MIME
type, specifying the file extension for Visio files (.vsd) and setting
up Visio as the program to use. It is conventional to name user-
defined MIME types with an x-extension.
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UNDERSTANDING MIME TYPES
MIME (Multipurpose Internet Mail Extensions) is a general purpose
encoding method for exchanging multimedia data over the Internet.

MIME types take the form type/subtype

where type is application, audio, image, text, or video,

and subtype is the actual file type (such as zip, mpeg, rtf ).

MIME types are defined by the author of a Web page; there are MIME
types currently in use for almost every type of file.

The following MIME types are included with Mosaic:

Type Subtype Description

application /commonground Common Ground files

application /iges IGES files

application /mathematica Mathematica files

application /msword Microsoft Word files

application /pdf Adobe Acrobat files

application /postscript Adobe Postscript files

application /rtf Rich Text Format files

application /wordperfect5.1 Word Perfect 5.1 files

application /zip ZIP (compressed) files

audio /aiff Audio Image File Format audio files

audio /basic Sun/DEC/NeXT audio (*.AU) files

audio /wav Microsoft Windows WAVE (RIFF) audio files

audio /x-midi MIDI audio files

image /gif CompuServe GIF images

image /jpeg JPEG compressed images

image /targa AT&T Targa images

image /tiff Tagged Image File images

image /x-win-bmp Microsoft Windows Bitmap images

text /html HTML formatted text files

text /plain Plain ASCII text files

text /richtext Richtext text files

video /mpeg MPEG movie files

video /msvideo Microsoft Video (.AVI) files

video /quicktime Apple Quicktime movie files
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SETTING UP TERMINAL PROGRAMS

If you need to connect to a telnet, TN3270, or Rlogin site, and have the
appropriate programs on your system, you can configure Mosaic to use
them automatically when connecting to those sites.

TO SET UP TERMINAL PROGRAMS:

1. Click Options on the Tools menu.

2. Select the Services tab in the Tools Options dialog box.

3. In the Terminal Programs box, fill out each of the boxes (Telnet,
Remote Login, and TN3270) with the full pathname of the program
you want to use. If you are not sure of the exact location of a program,
you can click the Browse button next to the program box to search for
the program on your system.
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USING PROXY SERVERS
Some networks are not directly connected to the Internet, but are protected
by Internet firewalls—software products designed to protect networks from
outside intrusion. If your network is behind a firewall, Mosaic will have to
communicate with proxy servers in order to access services on the Internet.
Proxy servers forward requests for information to the requested server and
return the information to Mosaic.

Mosaic supports proxy servers based on the ANS and CERN specifications.
Contact your network administrator for information on any proxy servers
used in your organization.

SETTING UP PROXY SERVERS

You can set up proxy servers for ftp, HTTP, S-HTTP, news, WAIS, and
gopher.

TO SET UP PROXY SERVERS:

1. Click Options on the Tools menu.

2. Select the Proxies tab in the Tools Options dialog box.

3. Specify the address for each proxy server that you will need to use. This
should be an IP address, such as 165.121.6.6, or a fully qualified domain
name, like proxy.circe.com. Note that proxy servers are often all found
on the same machine (with the same port).

If a specific port is also required to access a proxy server, type it in the
Port box next to the server name.

4. You can exclude specific domains from proxy access using the Exclude
Domain option. Specify the domain names you want to exclude; if you
have more than one domain name, separate the domains with commas.

When accessing a host on a specified domain, Mosaic will not go
through a proxy server. For instance, if you are accessing information
from your own network, you will not want to go through the proxy
server to retrieve the information. Also, if you have another domain
within your organization that is also behind your Internet firewall, you
may want to bypass the proxy server and communicate directly with
machines in that domain, since security is not an issue in those cases.

Once you define a proxy server for a service, Mosaic will always use a proxy
server to access that service, unless you are accessing a domain listed in the
Exclude Domain box.
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Chapter 2
SPRY Mail

SPRY Mail™ provides an efficient, easy to use way to send, receive and
store Internet mail.

In order to use SPRY Mail, you need to have a mail host; this is a machine
that is set up to receive your e-mail.  SPRY Mail requires that a POP3
server be running on the mail host in order for you to receive mail.

FEATURES
• Use Address Books to address mail to individuals or groups of

people.

• Send additional copies of mail with carbon copy and blind carbon
copy features.

• Automatically attach “signature files” to messages.

• Automatically encode/decode binary file attachments to mail over
the Internet using MIME or UUCode

• Insert text files into mail messages.

• Cut and paste between Mail and other Windows applications.

• Save the mail you send to a folder, automatically.

• Request a “return receipt” for mail you send, acknowledging that
mail was received.

• Spell check messages before sending them.

• Scroll through your mailbox with Previous/Next buttons.

• Drag and drop messages to custom folders or subfolders.

• Specify how often Mail checks for new messages, and the notifica-
tion method that should be used when messages are received.

• Show only the mail header information you wish to see.

• Change the font used to display mail.

• Sort mail by sender, date, subject, or size in ascending or descending
order.

• Read,  process, and compose mail when not connected to your mail
host.

• Store mail in a Remote inbox (storing messages on the mail host) or a
Local inbox (moving messages to your PC).
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STARTING MAIL
You can start Mail by clicking on the SPRY Mail icon.

The first time you start Mail, you will be asked to specify a directory for
your mail folders.  These are folders where your mail messages are stored;
you can create your own custom folders for mail.  The directory
\...\DATA\MAIL is suggested; click OK to accept this directory (it will be
created), or specify your own path and filename.  If you specify a new
directory, it will be created.

The login dialog will appear, prompting you to log into your Mail host.

Figure 2-1

You must fill out the Host, Username, and Password information for your
mail host in order to start Mail, even if you will be using the “Work
Offline” option (see the section below).  The login information is described
below.

HOST
Specify the address of the machine that you connect to in order to receive
your mail.  You can identify your mail host by its Fully Qualified Domain
Name (such as circe.odysseus.com) or IP address (such as
165.121.100.20), or by its host name in your hosts file.

USERNAME
Specify your username on the host you specified; this may be your “login
name” on that system.

PASSWORD
Specify your password on the host you specified.  You can have Mail
remember your password, so that you do not have to type it each time you
want to connect to mail.

Starting Mail
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Check Remember Password to have Mail remember your password.  The
next time you start Mail, your password will be automatically filled out in
the Login dialog.  Note that anyone will then be able to walk up and read
your mail.

When you’ve specified the Host, Username, and Password for your mail
host, click OK.  Mail will open the connection to the host that you specify
and you will see the Mail Console.

You can automate your login to fill in the Login dialog with any informa-
tion you choose, or can completely bypass the login dialog, if desired; see
the next section, “Automating your Mail Login” for information.

If you want to start Mail every time you start Windows, make a copy of
the Mail icon (by holding down [Control] before moving it) and move it
to your Windows Startup program group.

WORKING OFFLINE

Mail supports saving mail to mail folders and automatically downloading
mail to your PC.  This means that you can start Mail and work “offline”,
when not connected to your mail host.  You must still login to Mail with
your mail host, username, and password to use this feature, for security
reasons.

Check Work Offline in the Mail login dialog before logging in.  Mail will
open just as it would normally, but you will not be connected to your mail
host.  You can still read mail in your local folders, print mail, and compose,
reply and forward to mail.  Any mail you compose and send will be moved
to an Outgoing Mail box, and will be sent as soon as you have a connec-
tion.

When you are working offline, you can start a connection at any time; you
can press the Connect button on the Toolbar in the upper right hand
corner of your screen, or choose Connect in the Mail menu.  You can also
start a connection by choosing Send Now in the Mail menu, or by choos-
ing New Messages in the View menu; this will force Mail to make a
connection.

Likewise, when you are connected to your mail host, you can go offline at
any time by clicking the Disconnect button in the upper right hand corner
of the Toolbar, or by choosing Disconnect in the Mail menu.  (The
Toolbar button and menu item states will change depending on whether or
not you are connected to your mail host).

Starting Mail
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EXITING MAIL

You can exit Mail by choosing Exit from the Mail menu or clicking the
Exit button on the Toolbar.  You can also doubleclick on the Windows
System Menu to exit Mail.

Starting Mail
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AUTOMATING YOUR MAIL LOGIN

After the first time you login to Mail, Mail will automatically remember
the hostname (for your e-mail host) and your e-mail username.  The next
time you connect to Mail, the login dialog will be filled out (your password
will be filled out if you checked the Remember Password option).  You can
change the information that is automatically filled out in this dialog by
choosing the Login option in the Options menu.

However, you may want to bypass the login dialog altogether with Mail’s
command line options.  You can create an icon for Mail that will automati-
cally login and connect, as described below.

AUTOMATING YOUR LOGIN USING COMMAND LINE OPTIONS:

1) Copy your regular Mail icon by holding down Control and dragging the
icon to another location on your Windows desktop.  (This is suggested,
as you may not always want to log into Mail automatically).

2) Highlight the new Mail icon, and choose Properties from the Windows
Program Manager’s File menu.  A <Program Item Properties> dialog will
appear.  Edit the Command Line option, as described below.

Add the following options to the end of the Command Line field:

-h immediately followed by the hostname or address of your e-mail
host

-u immediately followed by your username on the e-mail host

-p immediately followed by your password on the e-mail host

Do not use spaces in between the parameters and the options.

For example, airmail.exe -hhost1.narnia.com -ulucy -paslan  would
try to connect to host “host1.narnia.com” and login as user “lucy”
with password “aslan”.

You may also want to edit the Description for the icon, so that you
know that this icon will automatically log you into Mail (sugges-
tion: Auto Start Mail).

3) Click OK.  The icon you created should now log you directly into your
Mail account when you doubleclick it.

Starting Mail
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THE MAIL CONSOLE

After you have logged in, the Mail Console will appear.  The first time you
start Mail, you will not see any messages.

Figure 2-2

The Toolbar at the top of the console contains Toolbar buttons that serve
as shortcuts for Mail menu items.  The Toolbar style can be changed
between Picture & Text, Picture only, and Text only by choosing Toolbar
Style from the Options menu.

The Status Bar at the bottom of the Console displays concise help for Mail
Toolbar buttons and menu items and will display the number of messages
in Mail and other status messages.

Both the Toolbar and the Status Bar can be shown or hidden by checking
or unchecking Status Bar or Toolbar in the View menu.  The Toolbar and
Status Bar will be displayed if checked.

Mail menu items and Toolbar buttons may be grayed out when a function
cannot be performed.

Mail displays your MAILBOX, an area in Mail where your mail messages
are stored.  You will see several system folders in this screen.  You can create
additional folders and subfolders for mail messages.  See “Using Folders to
Store your Messages” for more information.

In the Mail Console, you can read, print, save, and delete mail, and you
can use Toolbar buttons to compose new mail or reply or forward to mail
messages.

The next section describes how you can compose and send a message.
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COMPOSING AND SENDING MESSAGES
Mail allows you to compose new mail (or forward or reply to mail) with a
number of special features.  You can use Address Books to store your e-mail
addresses, cut and paste text from other applications, attach binary files to
your mail, and automatically attach “signature” files to your mail messages.

The <Compose Mail> screen is used to compose and send your messages.
You can type your message using standard editing keys, paste information
from Mail messages or other Windows applications, and attach files to
your message.

COMPOSING A MESSAGE:
Click the Compose button on the Toolbar (or click Ctrl-N)

or

Choose Compose from the Mail menu.

You will see the <Compose Mail> dialog:

Figure 2-3

There are four message fields shown: To:, Subject, CC:, and BCC:.

To: is the person or people to whom you want to send the message.  This is
the only field that you must fill out.  See the note on “Internet E-Mail
Addresses” at the end of this chapter if you are unfamiliar with e-mail
addresses on the Internet.

Subject is the subject of your message.   This is optional; you can fill it out
however you want.

Composing and Sending Messages
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The CC: and BCC: fields are optional fields allowing you to send copies of
this message to other people.  They work just like the To: field.  CC: will
send your mail to the people you specify, but the mail they receive will be
addressed to the person you specified in the To: field.  BCC:, or Blind
Carbon Copy, can be used to send a copy of the message to one or more
additional people, without the main addressee(s) being aware that the
message was sent to anyone else.

ADDRESSING A MAIL MESSAGE

There are two ways you can specify addresses in Mail: you can type them
directly in the fields shown, or you can select them from an Address Book.
Address books in Mail can contain the e-mail addresses of people to whom
you frequently send mail, so that you can select addressee names from a list
instead of typing their full e-mail address.

TYPING THE E-MAIL ADDRESS
Type the e-mail address for the person to whom you want to send mail in
the To: field.  If you want to add multiple addressees, separate them by
commas.

You can also type any additional addresses you want to cc: (carbon copy) or
bcc: (blind carbon copy) to in the CC: or BCC: fields, again separating
them by commas, if there are more than one.

USING AN ADDRESS BOOK
Since many e-mail addresses on the Internet are long and may be hard to
remember, you may want to use an Address Book in Mail to store peoples’
e-mail addresses and the “alias names” that represent them.  You can then
select or type in alias names instead of long e-mail addresses.  You can also
create group aliases, allowing you to send mail to groups of people.

For example, you often send mail to Tom, whose Internet e-mail address is
tom@jerry.tweety.com, so you put Tom’s name and e-mail address in your
address book, creating an alias name tom associated with that address.  Then
you can send mail to the alias name tom instead of having to type Tom's
address.

You may find it useful to create several different Address Books—perhaps
keeping separate personal and business Address Books, or grouping related
people together.  You can create as many Address Books as you want.

You can click the To:, CC:, or BCC: buttons in the <Compose Mail>
screen to bring up the Address Book dialog.  Alternately, you can open the
Address Book dialog by choosing Address Book from the Window menu.
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Figure 2-4

The <Address Book> dialog allows you to choose one or more people to
address your message.  You can also use this dialog to create a new Address
Book, select a different Address Book, or maintain your existing Address
Books—adding, editing, and deleting aliases.  These options are described
below.

This dialog contains a list of e-mail addresses, and corresponding alias
names for those addresses.  You can use the Alias Name search box to jump
quickly to any aliases in your list; just start typing the alias name, and the
cursor will move to the closest name in the list.  Click OK when you have
highlighted the address you want.   You can also use the arrow keys or the
scroll bar to move through the list of addresses, and doubleclick an alias
name for the address you want.  You will be returned to the <Compose
Mail> screen, and the address you want will be added to the To:, CC:, or
BCC: fields.

If you want to select several addresses, click on each address that you wish
to send your message to.  Each address you click will be highlighted.
Select All will highlight all the aliases in the Address Book.  To deselect an
address, click on the address a second time (this will turn off the highlight-
ing).  Click OK.  You will go back to the <Compose Mail> screen, and the
alias names you chose to send mail to will be added to the To or CC or
BCC box.

You can change Address Books, if you wish, by clicking the Open/New
button.

CREATING A NEW ADDRESS BOOK:
The first time you start Mail, you will see a default Address Book that has
been provided for you.

Composing and Sending Messages
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You can add your own e-mail addresses to this Address Book, if you want,
but you will probably want to create your own separate Address Book for e-
mail addresses (you can have multiple address books, if you like).  Address
Books are stored as files with the extension .als.

Click the Open/New button to switch to a different Address Book, and
specify a name for the new Address Book.  The name must be 8 letters or
less.  Mail will create your Address Book, and you will see an empty
Address Book dialog.

Figure 2-5

You can convert an existing text file into an Address Book, if you like.  Just
be sure the file has the following format:

Aliasname:Address1

Aliasname2:Address2

(and for groups)

Groupname:Address1,Address2,Address3

Save the text file in the directory where your address books (.ALS files) are
typically stored.  This is usually the \SPRY\DATA directory.

SELECTING AN ADDRESS BOOK:
Mail will always open the last Address Book that you used.  If you wish to
use a different Address Book, click the Add/New button.  You will see a
Windows file dialog that you can use to navigate your directories and
choose a different Address Book file.  (Note: this dialog will first look for
files that end in .als, although you can specify different filenames).

Composing and Sending Messages
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ADDING AN ALIAS TO YOUR ADDRESS BOOK:
To add a new alias to the current Address Book, select Add.  The <Address
Book Detail> dialog will appear.

Figure 2-6

Type an alias name, (a short, easy to remember name for the addressee),
and the corresponding Internet address.

You can use Paste to copy an Internet address from a mail message or from
another application screen.  You will first have to use Copy in the Mail
message or other Windows program (like Windows Notepad or Word) to
copy the Internet address to the Windows Clipboard.  You will then be able
to click the Paste button and insert the Internet address into the New
Internet Address box.  (This feature will also work for the New Alias Name
field.)  Note: when nothing has been cut or copied to the Clipboard, the
Paste button will be grayed out and unavailable.

EDITING ALIASES:
You can edit the name or e-mail address of someone in your Address Book
by selecting their name in the Alias Name list and clicking Edit.  The
<Address Book Detail> dialog will appear displaying the name and address;
make any changes you want to make and click OK.

DELETING ALIASES:
You can delete one or more aliases in your Address Book.  Click on the
aliases you wish to delete until all the aliases you wish to delete are high-
lighted.  Then click Delete to remove them from the Address Book.

There is no confirmation when you delete aliases.  You can restore
deleted aliases if you choose Cancel (instead of OK) before you exit
the Address Book dialog.

Note that any changes you make to the Address Book (adding, editing,
and deleting aliases) will not take effect until you click OK to exit the
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Address Book dialog.  If you wish to cancel all the changes (restoring
deleted aliases, removing newly added aliases, etc.), click Cancel.

USING GROUP ALIASES:
Aliases can be added for groups of users that you always send mail to by
adding a group name to an Address Book.  You can add a group alias just as
you would a standard alias, by clicking Add in the <Address Book> dialog.
Just assign a name for the group of people to mail to (i.e. Sales) and add
the Internet addresses of the people in the group separated by commas (i.e.
john@companya.com, jane@companyb.com, peter@companyb.com).

There is a limit to the number of characters you can type in the fields of the
<Add Internet Address> dialog; if you want to create a large group, you will
have to edit the Address Book you want to add the group to with a text
editor like Windows Notepad, using the following format:

Groupname:Address1,Address2,Address3  (etc.)

The maximum size of an Internet address is 1024 bytes (approximately
1024 characters of text).  When creating a large group in the Address
Book, do not let addresses exceed this length, as this may produce an
“overflow header” message in Internet mail and messages may not be sent
correctly.

Composing and Sending Messages
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TYPING THE MESSAGE

You can type the body of your message in the box below the message
header.  You can, if you wish, hide the message header by clicking the Hide
Header button (this will give you more room to type.  A Show Header
button will appear, allowing you to restore the header information.)

You can move around the screen using standard Windows editing keys.
Text will wrap around the screen.

You can copy or move text inside a message you are composing, or paste
text from another Windows application by using the Cut, Copy, and Paste
commands in the menus.  Highlight an area to be copied or moved using
your mouse, then choose Copy to copy it (or click Ctrl-C), or Cut to
move it (or click Ctrl-X).  The information will be stored in the Windows
Clipboard.  You can then use Paste (or click Ctrl-V) to insert the informa-
tion into a different area of the mail message, or use the Paste command in
any other Windows application.  You can also paste information from
other Windows applications into Mail.  Highlight the text you want to cut
or copy, and use that application’s cut or copy command.  When you
return to Mail, the Paste button will be active, and you can paste the text
into your Mail message.

CHECKING SPELLING IN YOUR MESSAGE
Mail includes a Spell Check feature.  If you have an application on your
system that uses Microsoft’s spelling dictionaries (such as Microsoft Office
or Microsoft Word), you will be able to use Mail’s Spell Check feature.

Select Spell Check in the Edit menu or by clicking [F7].  The Spell Check
dialog will appear and will immediately begin checking your message.

Figure 2-7

If any mistakes are detected, they will be listed as Not In Dictionary, and
one or more suggestions for the correct spelling will be listed.  Click Ignore
to ignore and not make a change.  To make a change, select a suggestion
from the list, or fill out the Change To: dialog, and click Change to change
the word.  You can also click Add to add the word to the dictionary.  The
spell check will continue checking; when it is complete, click Close to close
the dialog.
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OPTIONS IN THE COMPOSE MAIL DIALOG

You can choose the Hide Header button to hide the Header information
once you have filled it out.

Clicking the Options button in the <Compose Mail> dialog allows you to
choose two additional options:  requesting a return receipt, and specifying
the message encoding type to use.  These two options are described below.

REQUESTING A RETURN RECEIPT:
You can request a return receipt in Mail so that when you send a message,
you can have a mail message sent to you to acknowledge that the mail was
received by the remote mail server.  This does not acknowledge that the
person you are sending mail to has received the mail, only that the mail
arrived at the server. Check Request Return Receipt in the <Compose Mail>
Options dialog to request a return receipt.  When you send the message, a
receipt will be requested.  When the remote mail server receives the mes-
sage, you will be sent a mail message titled:  “Returned Mail: Return
Receipt”, which includes the body of the message you sent.  This is the
return receipt.

You must check the Request Return Receipt option every time you compose
a message to receive a return receipt; this option is not automatically
remembered.

SPECIFYING THE MESSAGE ENCODING TYPE:
You can send files along with your mail messages so that the person
receiving your mail can open or save the files you send.  (Sending a file
with a mail message is described in the next section.)  You can use either
MIME or UUCode to send your files; the method you should use to send
files should be dependent on the mailer the person on the other end will be
using.  Generally, if their mailer supports MIME, MIME is probably a
more efficient way to send the message attachment.

Check MIME or UUCODE in the <Compose Mail> Options dialog to
select which method to use to encode files.  The option you choose in this
dialog will be remembered and will be used for all mail messages until you
change it.

Composing and Sending Messages



2-16

SENDING A FILE WITH A MESSAGE

You can insert a text file into your mail message, or attach a binary file
(such as a graphics file, spreadsheet, word processing document, or other
file with special formatting) to your message, as described below.

INSERTING A TEXT FILE IN YOUR MESSAGE
You can insert a text file in your mail messages by placing your cursor in
your text where you would like to insert the text file, and choosing Insert
Text File in the Edit menu.  You will see a Windows file locate dialog; find
the text file you want to attach, and click OK.  The file will be inserted
into the body of your message at the current (or most recent) cursor
position.

ATTACHING A BINARY FILE TO YOUR MESSAGE
Binary files must be converted to a format that allows them to be sent over
the Internet.  In Mail, this is referred to as attaching a file.  Mail includes
two methods for doing this:  MIME and UUCode.  You can set which
option is used by clicking the Options button in the <Compose Mail>
dialog.

The recipient of your mail message must have a mailer, or other program,
that can read the attachments you send.  If their mailer does not support
automatic uudecoding or MIME, the mail message may appear as “gar-
bage” (unintelligible text on their screen) until they can decode it.

ATTACHING A FILE:

1) In the <Compose Mail> dialog, click the Show Attachment button.  An
empty window will appear right below your message, as shown below.

2) Click the Attach button.  You will see an <Attach File> dialog that you
can use to navigate your directories and choose a file to attach.  Select
the desired drive and directory and the filename that you want to attach.

You can also drag and drop files directly to the attachment window from
the File Manager or any other programs that support drag and drop.

You will see an icon appear in the attachment window for the file you
attached. (You can choose Remove to remove an attached file.)
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Figure 2-8

3) You can attach more than one file.  When you have finished attaching
files, you can choose Hide Attachment to return to your <Compose
Mail> dialog, if desired.  You can send the mail as you would normally,
by pressing the Send button.  When you choose Send, Mail will begin
attaching the file.  If the file is a text file, it should be attached quickly.
If it is a binary file, it may take some time to attach the file, as it has to
go through the uuencoding process (described above).  When the file is
attached, the mail message will immediately be sent.

Composing and Sending Messages



2-18

SENDING A MESSAGE

After you finish composing a mail message you can send it by clicking the
Send button.

You can cancel any message before pressing Send by doubleclicking on the
Windows System menu in the upper left hand corner of the <Compose
Mail> dialog.   You will be asked to confirm that you really don’t want to
send the message.  The <Compose Mail> dialog will close (none of the
information you typed will be preserved).

The first time you try to send mail, you will be asked to supply some
information about your mail host.

Figure 2-9

By default, Mail uses the SMTP (Simple Mail Transfer Protocol) method to
send mail.  To use this method to send mail, you need to fill out the
provided dialog.  The dialog has two fields, Return Address and SMTP
Host.  Your Return Address should already have been filled out, if you
provided the information during installation (this is the same as your e-
mail address).  Your SMTP host is usually the same as the Host you
connect to when you login.  Type the address for that host (in Fully
Qualified Domain Name format; i.e. circe.spry.com), unless you know that
you use a different SMTP host.

If you prefer to use POP3 as a send method, click Cancel.  In the <Prefer-
ences> dialog (accessed using Preferences in the Options menu), change
the Send Method to POP3, then re-send the mail message.

When you press Send, your mail will be sent immediately, if you are
connected to your mail host.  If you are not connected to your mail host
(working “offline”), the mail will be moved to the Outgoing Mail folder
until you are connected to the host, when it will be sent.

If you are not connected to the host, but want to send the mail immedi-
ately, you can choose Send Now from the Mail menu.  Mail will start
connecting to your host and will, if successful, send your mail.

Mail will add hard carriage returns to the end of each line of text when
you send a message so that the message can be sent successfully over the
Internet.
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You will see a “Message sent successfully” message in the Status Bar after
the mail message is sent.

OPTIONS WHEN SENDING MESSAGES

Several options are available when sending messages.  These options can be
set in the Mail <Preferences> dialog.

Figure 2-10

CHOOSING THE MAIL SEND METHOD
By default, Mail uses SMTP (Simple Mail Transfer Protocol) to send mail.
This requires you to supply a return mail address (as described above).  You
can also choose to use POP3 to send out mail if your mail host features the
extended POP3 protocol (SMTP should work for most cases; contact your
mail administrator if you are not sure which protocol to use).  You can
switch between protocols by choosing Preferences in the Options menu.
You will see the <Preferences> dialog.

You can also change the nickname that appears in your mail messages by
changing the Return Address field.  Be sure to use one of these sample
formats: rapunzel@castle.com (Rap), “Rap” rapunzel@castle.com, or Rap
<rapunzel@castle.com>, where Rap is the nickname you want to use.

SAVING SENT MAIL
Mail allows you to save sent mail in a Sent Mail folder, automatically.  The
Sent Mail folder is a system folder and cannot be deleted.  By default, this
folder is not used, since keeping sent mail will use up disk space on your
hard drive.
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Check the Keep a copy of outgoing messages in Sent Mail folder option in the
<Preferences> dialog to save mail to the Sent Mail folder.

All messages you sent will automatically be stored in the Sent Mail folder.
You can treat messages in this folder as if they were in any other folder;
deleting them, moving them to other folders, etc.

CONTROLLING THE MESSAGE WIDTH
Mail automatically inserts a carriage return at the end of each line before it
sends a composed mail message (this must be done so that the message can
be sent and received properly over the Internet).  Since most mailers can
display messages at least 80 characters across, Mail by default adds the
carriage return after the 80th character on each line.

Some mail programs can view messages wider than 80 characters.  You can
change the message width in Mail so that more (or less) text displays on
each line by changing the value of the Column field.  (The value of this
field must be at least 32; if you supply a number less than 32, 32 will be
used.)  Alternately, you can have mail break the message at the current
window width by selecting the Current Window Width option.  The
carriage returns will be added at the end of each line as the message is
displayed.

ATTACHING A SIGNATURE FILE TO A MESSAGE
You can automatically attach a signature file to your message every time
you send mail, containing your name and other contact information.  This
must be a text file.  You can specify the name of this file using the Prefer-
ences option in the Options menu.  For the Signature File, specify the path
and filename of the file that you want to attach to your mail messages,
such as C:\FILES\ADDRESS.TXT.

The file you specify will automatically be inserted at the end of the message
whenever you start to compose mail.  You can delete or change the text as
you wish.

The other two options in this dialog, Mail Notification and Check New
Messages, are explained in the next section, “Receiving Messages”.
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RECEIVING MESSAGES
When you first start Mail, you will probably not have any messages in your
MAILBOX.  You can choose how exactly messages are treated when they
are received, as described below.

CHOOSING AN INBOX

Mail gives you two options for incoming mail:

• Keeping the mail in a Remote Inbox (leaving your mail on the host)

• Move incoming mail to a Local Inbox
The  default option is Remote Inbox. When you are using this option, a
Remote Inbox will display in your Mail folder list when you are connected
to your mail host.  All new mail will be kept on your mail host until you
move it to a local folder or delete it.  Only mail that you move to local
folders will be available “offline” (when not connected to your mail host).
You will have fast access to new mail messages (since new mail is not
moved to your PC).  Also, since your mail is kept on your mail host, you
can still access old mail from any location.

You can, if you wish, choose to store mail in a Local Inbox. If you use a
Local Inbox, all new mail you receive will automatically be moved to an
Inbox folder on your PC and removed from your mail host.  (Mail will
take some time at startup to do this.)  Old mail messages will automati-
cally be available “offline” (when you are not connected to your mail host),
and you will minimize the disk space you use on your mail host.  However,
since the mail is removed from your mail host, you will only be able to
access this old mail using your PC.

You can change which Inbox you are using by choosing Preferences in the
Options menu.

The Inbox Location will indicate which inbox you are currently using.
Click Change to change the Inbox you are using, and choose which Inbox
type you would like to use.  The change you make will not take effect until
you exit and restart Mail.

If you change from Remote Inbox to Local Inbox, the Remote Inbox folder
will no longer display (all messages in the Remote Inbox will be moved to
your Local Inbox the next time you check for mail).  However, if you later
change back from Local Inbox to Remote Inbox, you will not be able to
remove the Inbox (Local Inbox) folder; it is a system folder and cannot be
removed.
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CHECKING FOR NEW MESSAGES

When you are connected to your mail host, Mail will check for new
messages as often as you specify.  Mail, by default, checks every five
minutes.  Any new messages will appear in your Inbox as “unopened”
yellow envelopes.  They may appear in different places in your Inbox,
depending on how you are sorting your mail (see the next section, “Dis-
playing and Sorting Mail Messages” for information on sorting mail).

You can change how often Mail checks for new mail by choosing Prefer-
ences in the Options dialog and specifying a different value for checking
mail.

Figure 2-11

Change the Check mail every __ minutes while working online value to
reflect how often you want Mail to check mail.

You can also check for messages immediately, whether or not you are
connected to your mail host, by choosing New Messages from the View
menu, or by pressing F10. You can only check for messages if you are
connected to your mail host.

MONITORING FOR NEW MESSAGES
You may want to be notified when new mail arrives without having to
leave Mail open on your desktop; you can do this by minimizing Mail.
Click the Minimize arrow in the upper right corner of the Mail Console
(or choose Minimize from the Windows System Menu).  You will see a
Mailbox icon in the lower left hand corner of your Windows Program
Manager (if your Windows Program Manager is maximized or large, you
may not see this icon).

Receiving Messages



M
ail

2-23

When a message is received, the flag on the mailbox will go up, and a letter
will appear in the mailbox. You can doubleclick on the Mailbox icon at any
time to open Mail and read your new message(s).

You can also choose how you want to be notified about new mail by
changing the Notification option in the <Preferences> dialog.  Check the
notification option or options you would like to use.  Three options are
listed:

Popup Box
When new messages arrive, a dialog box appear in the middle of the
screen, notifying you that you have new mail.  This box will disappear by
itself in a few seconds, or you can click on it with your mouse to make it
go away.

Sound
You will be notified when new messages arrive by a beep or other system
sound (if you have a sound card, you can change the sound that is used by
changing the SPRY Mail sound in your Windows Control Panel.)

Flashing Cursor
The cursor in the application you are currently using will flash when mail
is received.

You can change how mail messages are displayed and sorted, as described in the
next section.
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DISPLAYING AND SORTING MESSAGES
When you receive mail messages, the MAILBOX lists the name/address of
the mail sender, the date the message was sent, and the size and subject of
the message.  You can specify which font is used to display the messages,
define which mail header information is displayed, or specify how to sort
messages and which message details to display, as described in the sections
that follow.

SETTING THE MAIL FONT

You can choose Font in the Options menu or click the Font button on the
Toolbar to change the mail display text to different fonts, sizes and styles.
This is for display purposes only--Internet mail is in ASCII format.  The
Mail screen will resize after you change fonts.

Mail only allows for fixed size fonts, so you will not be able to select some
of the standard Windows fonts in this dialog.

DISPLAYING HEADER INFORMATION

Mail allows you to specify which mail header information to display.  This
is information such as the mail subject, who the mail is addressed to (To:,
CC:), the date, and much other additional information.

By default, all the header information will be displayed in a mail message.

Figure 2-12

The information you see may vary according to the mail program/host
being used by the person sending mail to you.

You may not want to display the entire mail header; you can specify which
information you really want to see.  Click Message Headers to display the
<Message Headers> dialog.
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The selection All (display all header information) is checked on, by default.
You can select None to display no header information (unless you think
you can tell who sent you mail by the content of their message, this option
may not be helpful).

To select which message headers you want to display, choose Selection:.
You will then be able to click on the items you want to display in the
message header.

Figure 2-13

If you are not sure which items you will need, look at some of the messages
you’ve received to determine what information you find useful.  The names
of the items in the Selection field above should be the same (or very
similar) to the actual header information you see.

When you have chosen the items you want to display, click OK.  If you
have any messages open, you will see a dialog asking you whether you want
to have this change take place immediately; click OK to change the headers
on any open messages.  You will then see new headers on all messages you
receive, displaying just the information you specified.

Figure 2-14
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DISPLAYING AND SORTING MESSAGE DETAILS

Mail will automatically display all the details of your mail messages:  the
sender, date, size, and subject.  You can choose whether or not you want
to display the date and size of messages.  Choose Partial Detail from the
View menu; you can then uncheck the Date or Size option to hide these
details (you cannot hide sender or subject information).  Choose All
Details from the View menu to again display all the message details.

You can easily change how the messages in your mailbox are sorted by
clicking the detail fieldbar.

Figure 2-15

Click on the From, Date, Size, or Subject portion of the fieldbar to sort
the mail using that detail.  A checkmark will appear next to the option you
selected.  (You can also change the sorting by choosing the appropriate
Sort by... option in the View menu.)  The field that is currently being used
to sort messages will appear in the fieldbar with its first letter underlined.

You can also change the width of any of these fields by moving the cursor
to the dividing line between the fields on the fieldbar.  The cursor will
change to a double-headed arrow, and you can widen or narrow the fields.

By default, the mail will be sorted in Ascending order, as follows:

From: alphabetical, a-z
Date:  oldest to newest
Size:  smallest to largest
Subject: alphabetical, a-z.

You can change the order in which the messages are sorted, from Ascending
to Descending.  You change the Mail from Ascending to Descending order
by holding down [Control] and clicking the fieldbar.  The View menu will
allow you to change that sort order by clicking Sort in Ascending or Sort
in Descending from the View menu (this menu option will change
depending on how you are currently sorting messages).

The Date of the message reflects the date it was sent, not the date the
message was received.  Messages sent to you from other time zones may
have a later date/time than messages you receive locally; if you are sorting
by date, local messages will appear in front of messages with a later date.

Displaying and Sorting Messages



M
ail

2-27

WORKING WITH MESSAGES
Mail allows you to read your mail messages and save them to a file or
folder, delete them, print them, or forward or reply to messages, as de-
scribed in the next few sections.

SELECTING MESSAGES

You will need to select Mail messages in order to read, save, or delete them.
Select a message by clicking the message name with your mouse.  To select
additional messages, hold down the [Shift] or [Control] key while you click
on message names.

[Shift] will select all the messages between the currently selected message
and the message you clicked on.

[Control] will select only those messages you click on, allowing you to
select messages that are not next to each other.

You can also click on a message and drag your mouse to highlight a series
of messages.

Selecting multiple messages is useful when you are deleting or saving
several messages, and can also be used to read messages in a particular
order (or skip reading messages you do not want to read).
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READING MESSAGES
You can read Mail messages one at a time or in a sequence (reading
through selected messages in order).

READING MAIL MESSAGES:

1) Select one or more messages.

2) Click the Read button on the Toolbar

or

Choose Read from the Mail menu

or

Press [Enter]

You can also double-click on the message name to read the message
immediately.

You will see the first message you selected appear in a window with the
Subject of the message as the window name.  Use the scroll bar to scroll
through and read the message.

 You can change which message header information (Received by, Date, To:,
etc) is displayed using the Message Headers option in the Options menu;
see the last section for information.

The Previous and Next buttons on the Toolbar, the Previous and Next
menu items in the View menu, and the Ctrl-PgUp and Ctrl-PgDn keys
can also be used to move up and down in the message list (the names
Previous and Next are a little deceptive; regardless of your sort order,
Previous is above the message you have selected, or are reading, and Next is
below it).

If you have selected multiple messages to read, Previous and Next will only
scroll through the messages you selected.

You can minimize a message you just read if you might want to refer to the
message later.  Click on the Minimize arrow in the upper right hand
corner of the <Read Message> screen to minimize the message.  Only one
message at a time can be minimized, and if Mail is closed, the message will
also be closed.
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You can copy information from the mail message to the Windows Clip-
board so that it can be pasted into Mail or another Windows program.  To
copy text, highlight the text with your mouse and choose Copy from the
Edit menu (or click Ctrl-C); the text will be copied to the Windows
Clipboard.  You can then Paste the information using Paste (or Ctrl-V) in
Mail and other applications.

READING FILES IN YOUR MESSAGES

If another SPRY Mail user sends you a file, or if you receive files sent from
a mail program that supports MIME, the attached file will display in your
received message’s attachment window as an icon.  SPRY Mail uses the
associations in your Windows File Manager to try to determine the type of
the file and display the correct icon.

If the file association exists, you can immediately doubleclick on the icon
and start the associated application (see your Windows manual for more
information on the association feature in File Manager).

You can also click on the Save button in the attachment window to save
the file to your PC.  SPRY Mail will present you with a standard Windows
file save dialog and will allow you to save the file to your PC.

If SPRY Mail cannot convert/display an attached file, the file will not
display properly as an attachment, and will appear as “garbage” text in the
mail message body.  This will happen if the file was sent in a format (such
as bin-hex) that SPRY Mail does not recognize.  In these cases, you will
need to save the mail message containing the attachment(s) to a file and
use a separate utility program to extract/translate the file.
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PRINTING MESSAGES
You can print the current mail message you are reading, or you can select
and print multiple messages from the MAILBOX screen.

Click the Print button on the Toolbar or choosing Print from the Mail
menu to print your mail message(s).  A <Print> dialog will appear; you can
click OK to print the message.  If you wish to change the current printer,
click the Setup button in the <Print> dialog. The message(s) will be
printed.

FINDING MESSAGES
Mail provides a Find feature to enable you to locate a message in a list of
messages.  You can search for any text in the message detail header:  Sender
Name, Date, Size, or Subject.

Mail does a search starting from the currently highlighted message down to
the bottom of the message list.  You may, therefore, want to highlight the
first message in order to do a search of the entire list.  Mail will only search
the messages currently being displayed.

To search for message text, choose Find in the Edit menu.  You will see a
<Find> dialog box.  Type in the exact text you want to search for (Mail
searches are case sensitive; you may have to do two searches if you’re not
sure whether the word is capitalized).  Click OK to search.  Mail will find
and highlight the first occurrence of the text or tell you the text could not
be found.

If you want to search again, choose Find Next from the Edit menu or press
[F3].  The next occurrence of the text will be highlighted.  You can con-
tinue to use Find Next to highlight all occurrences of the text.  This may
be helpful because it enables you to then read, save, move or delete all the
highlighted messages, if desired.

Printing Messages
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USING FOLDERS TO STORE YOUR MESSAGES
Mail provides folder capability to allow you to organize your saved mail.  If
you store your mail in folders, you can work with the mail when you are
not connected to your mail host (when working “offline”).

When you first use Mail, you will see several pre-defined folders in the
MAILBOX screen.  These are system folders; they cannot be removed.

You can create your own custom folders for storing mail.  Creating, using,
and deleting folders is described below.

CREATING A FOLDER:
You can create additional folders and subfolders for mail messages by
choosing New Folder from the Mail menu.

You will be asked to specify a name for a new folder; specify any name you
choose.  If you click OK, the folder will be created as a folder hanging off
the Root Folder.

Figure 2-16

You can also make the new folder a subfolder of another folder, if you wish,
by highlighting the folder name under Subfolder of:.

Figure 2-17

Using Folders to Store your Messages



2-32

You can create folders many layers deep, if you choose.  You can move
messages between folders at any time.

New folders you create will display in the left hand panel of the Mail
Console.

Figure 2-18

Folders in Mail behave very similarly to folders (directories) in Windows
File Manager.  When you doubleclick on a top-level folder, it will display
any messages inside it, as well as any subfolders.  Those subfolders in turn
can be opened to display messages and other subfolders.  Clicking on the
folders again will close/collapse them.

MOVING MESSAGES TO A FOLDER:
Moving messages to a Mail folder is easy.  There are two ways to move
messages:

Select one or more messages using your mouse, and drag and drop them
onto the folder where you want to put them.

or

Choose Move from the Mail menu and specify which folder to put the
messages in. A dialog will appear asking you to specify a folder for the
message(s).  Click on the folder name to select it (doubleclick on a folder
name to display any subfolders).  Click OK; the messages will be moved
to the folder you specified.

Using Folders to Store your Messages
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MOVING A FOLDER:
You can move a folder or subfolder to another position in the Mail folder
tree by dragging and dropping the folder to the position you desire.
Alternately, you can  choose Move Folder from the Mail menu; indicate
the destination folder where the folder should be moved (if no folder is
selected, the folder will be moved under the Root Folder.)  Click OK; the
folder will be moved.

DELETING A FOLDER:
You can delete any folder by selecting it and choosing Delete Folder from
the Mail menu.  You will be asked to confirm that you want to delete the
folder.

Deleting a folder will delete any subfolders and any messages in the
folder in subfolders. Be sure that this is what you want to do.

Using Folders to Store your Messages
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SAVING MESSAGES TO FILES
You can save one or more Mail messages to a file, if you’d like.  Only text
information in the message will be saved.  (You might want to use the
information in another application).

You may find it more useful to save Mail messages to folders; see “Using
Folders in Mail,” for more information on how to create and use Mail
folders.

SAVING MAIL MESSAGES:

1) Select one or more messages from the MAILBOX.  You can also save a
message you are currently reading.  If you select several messages, the
messages will all be stored in one file.

2) Click the Save button on the Toolbar

or

Choose Save from the Mail menu.

You will be asked to specify a directory and name for the text file.  By
default, messages will be saved to \...\DATA in your installation directory.

Your file will be saved in ASCII text format and can be read by an ASCII
text editor such as Windows Notepad.  Note that if you save many mes-
sages to a text file, you may be unable to open it in Windows Notepad;
open the file in Microsoft Write or another word processor.

If you want, you can append messages to an existing file (add messages to
the end of a text file); just specify an existing filename when you save the
message.  Mail will ask you to specify whether you want to append the
message to the file or overwrite the file. Choose Append to add the mes-
sage to the file.

Saving Messages to Files
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DELETING MESSAGES
You can delete messages from Mail several ways.

DELETING MAIL MESSAGES:

1) Select one or more messages.  You can also delete the message you are
currently reading.  (The Find command may be helpful in specifying the
messages to delete.)

2) Click the Delete button on the Toolbar

or

Choose Delete from the Mail menu

or

Press the Delete key on your keyboard.

When you delete messages, you will be asked to confirm deleting each
message that you have specified.  Click OK to delete the message (messages
are identified by the message number in the list).

If you delete a message from the Remote Inbox folder, it will be deleted
immediately (after asking you for confirmation, as described below).
However, messages in folders (or the Local Inbox) will not be deleted
immediately; they will be moved to the Waste Basket folder.  This folder
will be emptied and all messages deleted whenever you exit Mail if Empty
Wastebasket on Exit (in the Options menu) is checked.  If this option is
not checked, the messages will not be deleted unless you select them in the
Waste Basket folder and choose Delete.

CONFIRMING MESSAGE DELETION
You can bypass confirming each message you delete by unchecking Remote
Message Delete using the Confirmation option in the  Options menu.
When you delete files, if this box is checked, you will be asked to confirm
that you want to delete the selected files.  If the box is unchecked, files will
be deleted without prompting.  If you often delete large numbers of files,
you may want to leave this option unchecked so that you will not have to
confirm each file that you delete.

Deleting Messages
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FORWARDING MESSAGES
You can forward any of your mail messages to other people.

You can forward a message you are currently reading, or you can forward a
message listed in your Mail Console by highlighting it before choosing
Forward.

The original message will be enclosed by two lines, Begin Message and End
Message.  You can add your own text to the message before you forward it.

FORWARDING A MESSAGE:

1) Open the message you want to forward, or highlight the message name
in the Mail Console.

2) Click the Forward button on the Toolbar

or

Choose Forward in the Mail menu.

You will see the <Compose Mail> dialog.  See “Composing Messages”
earlier in this chapter for more information on composing and sending a
message.

Forwarding Messages
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REPLYING TO MESSAGES
You can reply to any mail messages you receive.  This will send a reply to
the message’s sender, using as a subject the Subject line of the received
message (i.e. a reply to mail with subject “Tesseract” would read
“RE:Tesseract”).  You can choose whether or not to include the message
text.

1) Open the message you want to reply to, or highlight it in your Mail
Console.

2) Click the Reply button on the Toolbar

or

Choose Reply in the Mail menu.

You will be asked  which method you want to use to reply to the mes-
sage:

• To Sender: The reply message will be sent to the person who sent the
mail to you.  This is the default reply method.

• To All: The reply message will be sent to the person who sent the
mail to you and all others who the sender CC’d to on the mail.

• To Sender Include: The reply message will be sent to the sender
only, and will include the original received message.  The original
message will be labelled as being from you, and the message text will
be indicated with text with the > sign at the left margin.

• To All Include: The reply message will reply to the sender and all of
the people that the sender CC’d to, and also will include the original
receiving message described above.

3) Choose the method you want to use to reply to the message, and click
OK.   You will see the <Compose Mail> screen.  See “Composing
Messages” for more information on composing and sending a message.

If you do not want to have to specify a reply method each time you reply to
a message, you can disable the prompt for reply method that appears by
unchecking Reply Method in the <Confirmation> dialog (accessed using
Confirmation in the Options menu).  Reply to a message using your
preferred reply method before disabling the reply method confirmation, so
that the last reply method you chose will be used whenever you choose
Reply.
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NOTE:  INTERNET E-MAIL ADDRESSES
An e-mail address can take several formats; the standard Internet format is
name@place.ext, where name is the sender’s name, and place.ext is the
domain name for the sender.  The sender’s name and domain name are
typically separated by an @ symbol.  The domain name usually represents
the company, university, or organization name that the mail is routed
from.  For instance, holmes@mycroft.com might be from user holmes,
working at Mycroft Corporation; lovecraft@cthulhu.miskatonic.edu might
be from user lovecraft at Miskatonic University.

For some addresses on the Internet, like addresses from CompuServe or
America Online, you will have to use a slightly different format.  Some
popular address formats are listed below.

For CompuServe, the address is a number (such as 76543,123).  Change
the commas to periods and mail to address@compuserve.com
(76543.123@compuserve.com).

For America Online and Delphi, the address is usually a first initial and
last name (sholmes); address the mail to the address@aol.com for America
Online (sholmes@aol.com), or address@delphi.com for Delphi
(sholmes@delphi.com).

For Prodigy, the address is usually assorted numbers and letters
(UMH999A), address the mail to address@prodigy.com
(UMH999A@prodigy.com).

For MCIMail, you might be given either a name, or a 7-digit “phone”
number; address mail to firstname_lastname@mcimail.com or
1234567@mcimail.com (omit the hyphens in the number).

Mail also supports UUCP style addressing; i.e. holmes@mycroft.com could
also be addressed as mycroft.com!holmes.



Chapter 3
SPRY News

SPRY News™  is a news reader program allowing you to access news
services on the Internet, featuring a straightforward, easy-to-use Windows
interface allowing you to read, save, and post news articles.  SPRY News is
a vast improvement over traditional command line based news readers,
with Windows fonts and screens, an intuitive newsgroup browser, quick
subscription and unsubscription to newsgroups, an efficient article editor,
and intuitive menus and buttons.

FEATURES
• Group commonly read newsgroups in personal groups.  Easily

subscribe and unsubscribe to newsgroups by dragging and dropping
them to personal groups.

• View all newsgroups on a news server in tree or list format using the
Newsgroup Browser.

• Read related news articles (threading).

• Decode single and multi-part sound, video, and graphics files in
news articles.

• Copy, save, or print News articles.

• Post articles; paste information from other Windows applications, or
post binary file attachments.

• Display and sort  news articles by news attributes (subject, date, who
posted the articles).

• Catchup feature lets you mark all current news articles as read.

• Specify which news article header information to show.

• Change the news server you are using during your news session.

• Compose articles and subscribe and unsubscribe to newsgroups
when offline.

• Support for ROT13 allows you to view “encrypted” articles.
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WHAT IS NEWS?
Many people with Internet access use Internet news services.  You can think
of an Internet news service as a large computer bulletin board which can be
accessed over the Internet and used as a forum for conversation, discussion,
and information exchange.  A news service contains newsgroups, discussion
areas dedicated to topics both educational and  recreational.

Newsgroups usually have a naming convention, such as
category.subcategory.subcategory, where the category is a general category
of topics (these are predefined on most newsreaders; rec is recreational,
comp is computers, biz is business, etc), and subcategories give you
specifics on room content.  Some possible newsgroups might be:
rec.camping, comp.protocols.tcp-ip, comp.languages.c++, alt.tv.seinfeld,
comp.unix.questions, and alt.fan.comics.

You can add to the discussion in a newsgroup by adding your message; this
is called “posting”.  Messages posted to Internet news services are called
articles.  News is not only a forum for discussion, it is a powerful medium
of exchange; aside from discussions, news articles can contain binary files
such as program files or source code.

The most well known and widespread news service (and the one you are
most likely to use) is USENET News.  USENET News began as a small
service used by programmers and researchers and has grown into a  huge
worldwide news service used by a wide variety of people, from educational
and business professionals to students and casual users.  USENET News is
a noncommercial service dedicated to information exchange.  The
USENET News has thousands of newsgroups which are updated con-
stantly.

What is News?
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HOW DO I CONNECT TO NEWS?
You connect to a news service by connecting to a News Server, a machine
which uses the Network News Transfer Protocol (NNTP) to access
USENET or another news service.  Although many News Servers may
have access to the same news service (the USENET is the most common),
not all News Servers will necessarily have all available newsgroups.  The
administrators of News Servers can choose which newsgroups to allow on
their News Servers; some businesses do not allow recreational newsgroups,
for instance.  Thus, you may find different newsgroups on different News
Servers, even though they may both be drawing from the same large pool
of newsgroups.

Some News Servers may also be read only; meaning that users of that
News Server can read articles, but cannot post articles to any of the
newsgroups.

WHICH NEWS SERVER SHOULD I USE?
During the Internet In A Box installation, a default news server address,
news.interserv.com, was suggested for your news server.  Unless you
changed this address during the installation, SPRY News will automatically
connect to this news server to display USENET news.

If you set up an account with InterServ, you will have full access to this
news server, and will be able to view all the newsgroups and articles and
post articles to the newsgroups.

However, if you set up an account with another Service Provider, you will
only have limited access to this news server; you will see a limited number
of newsgroups, and will not be able to post news articles.  If your Internet
Service Provider has a news server available, you will probably want to set
up News to connect to this news server in order to have full access to
USENET news.

There are two ways to change the news server that is used in SPRY News;
you can use the <Default Hosts> dialog in the Configuration Utility (click
the Hosts button in the Configuration section), or you can choose Startup
in the SPRY News Options menu to specify the new news server to use.

What is News?



3-5
 New

s

STARTING NEWS

You start News by clicking on the SPRY News icon.  When you start
News, it will immediately start connecting you to the news server that was
set up during the installation.   You will see the News Console.

Figure 3-1

The Toolbar at the top of the News Console contains buttons that serve as
shortcuts for News menu items.  The Status Bar at the bottom of the
Console displays concise help for News buttons and menu items and will
display News status messages.  Both the Toolbar and the Status Bar can be
shown or hidden by checking or unchecking Status Bar or Toolbar in the
View menu, and the Toolbar Style can be changed by selecting Toolbar
Style in the Options menu.

When you connect, the News Status Bar (at the bottom of the Console)
will read “Trying to connect to <News Server>”, and then, after a connec-
tion is established, the message “Connected to <News Server name and
information>”.

You will then see the Newsgroup Browser, displaying newsgroups available
on the news server.  You will also see Personal Groups, collections of related
newsgroups.  Once you’re familiar with News, you can create your own
Personal Groups; see “Using Personal Groups” later in this chapter for
more information.

You can disconnect from a News Server at any time and work off-line by
choosing Disconnect from the File menu. See the “Working Off-Line in
News” section for more information.

Starting News
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EXITING NEWS

You can exit News by choosing Exit from the File menu or clicking the
Exit button on the Toolbar.  You can also double-click on the Windows
System Menu to exit News.

WORKING OFF-LINE IN NEWS

You can work off-line in SPRY News.  This feature is most useful when
using News over a SLIP or PPP dialup account.  When you wish to work
off-line, choose the Disconnect option in the File menu. To save connect
charges, be sure to disconnect the Dialer application, as well.  Working
off-line is designed to allow you to perform administrative functions
without incurring connect charges with your Internet Service Provider.
The most common off-line functions you might perform include creating
and updating personal groups (subscribing and unsubscribing to news-
groups), examining the Newsgroup Browser, setting preferences and
options, and performing searches.  While off-line, you can also compose
posts, follow-ups, and replies, although you must reconnect before sending.

When you are working off-line, you can only work with the elements you
see on your screen.  In other words, you may scroll through the list of
articles in a newsgroup while off-line, but you cannot open and read
articles while off-line.  If you doubleclick on an article to read it while off-
line, SPRY News will try to reconnect to your News Server.  If you have
selected the option Prompt Before Reconnect from the <Other Options>
dialog, SPRY News will prompt you and ask if you would like to reconnect
to your server.  It is recommended, if you plan to work off-line, that you
select this option or have the same option set in the Dialer, so that you will
know when SPRY News is reconnecting.

You can connect News again by clicking the Connect button in the File
menu; this will be available only when you are disconnected from News.

If you are working off-line to save dialup connection charges, be sure
you disconnect the Dialer application, as well as News.  The Discon-
nect button in News does not automatically disconnect the Dialer, so
charges can still be incurred.

Starting News
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BROWSING NEWSGROUPS
You can immediately open any of the included Personal Groups by double-
clicking on the newsgroup names displayed in the Personal Group screen
(some personal groups may be minimized, just doubleclick on the mini-
mized icons to open the personal groups).  This will display a list of all the
articles in that newsgroup.

News includes a Newsgroup Browser that allows you to browse through all
the newsgroups on a News Server and view the articles in any newsgroup.
The Newsgroup Browser is automatically opened when you first open
News; you can leave it maximized on your desktop, if you wish, or mini-
mize it and only maximize it when you need to retrieve newsgroups.

Figure 3-2

Loading in the Newsgroup Browser will take varying amounts of time,
depending on how many newsgroups are found on the News Server you
selected, and whether Auto Refresh is on (see “Refreshing Newsgroups and
Articles” for more information.).  The first time you launch SPRY News
after installing it, you may notice that it takes a very long time to load.
SPRY News is recording all the available newsgroups to a file stored in your
PC.  The next time you start News, this will not take a long time.

When you first maximize the Newsgroup Browser, it lists all the news-
groups available on the News Server you are using, in list format.  This lists
every newsgroup in alphabetical order from a-z.

You can scroll through the list of newsgroups using the arrow keys or Page
Up and Page Down keys, or scroll through them using the Windows scroll
bar.  When you find a newsgroup that interests you, doubleclick on the
newsgroup folder.  This will display a list of all the articles in that news-
group.  You can then read any of the articles you choose.

Browsing Newsgroups
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USING THE NEWSGROUP BROWSER IN TREE STRUCTURE:
Tree mode is also available for the Newsgroup Browser.  This allows you to
expand and collapse newsgroups, making browsing  easy and fast.  You can
change from List mode to Tree mode (and back) using the Tree and List
commands in the View menu.

When you use the Newsgroup Browser in tree mode, you will first see only
the general categories for newsgroups. (e.g. comp is the category for all the
computer related newsgroups, like comp.lang.unix and comp.os.windows;
seattle is the category for all the Seattle-based newsgroups, etc.)

Any folder displaying a + contains sub-categories.  These categories make
up the newsgroup name.  In other words, to get to newsgroup
alt.alien.visitors, you would open the folder alt then alien then visitors.

Figure 3-3

When you have fully opened a newsgroup, the articles in that newsgroup
will display in an article screen.  See the next section, “Reading Articles”,
for more information.

Browsing Newsgroups
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READING ARTICLES
When you open a Newsgroup in the Newsgroup Browser or from a
Personal Group, you will see a “Transferring Article List” message, and a
Status Bar indicator that will tell you how many articles are being read in.

The newsgroup window will appear.

Figure 3-4

The newsgroup window title bar displays the name of the newsgroup, and
the articles will initially display ordered by subject.  The newsgroup
window fieldbar displays the article status, author, date, number of lines,
and subject of the article.  You can change how the articles are sorted and
which of these details are shown; see “Displaying and Sorting News
Articles” for more information.

News also allows you to sort by threading; if this is the case, your screen
will appear different.  See “Using Threading” for more information.

The article status (book icon) next to the article shows you whether or not
you have examined the article yet.  Once you have opened the article, the
status will change to an open book.

The Author: information tells you the name or nickname of the person
who posted the article (the full Internet address can be found inside the
header of the article).

The Date: information is the date the article was posted.

Reading Articles
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The Lines: value displays the number of lines in the posting; this will give
you some idea of how long it will take to retrieve the article.

The Subject: information shows the subject of the news article.  A RE:
preceding the subject indicates that this is a follow-up to a previous article
with that subject header.  There may be many follow ups to a single article.

The Window Status Bar at the bottom of the Newsgroup window displays
features of the currently selected article: the title of the article, the author,
date and time of posting, and the size (the number of lines in the article
and the size in bytes).

READING AN ARTICLE IN A NEWSGROUP:

1) Select the article.

2) Doubleclick on the article name

or

Choose Read in the Article menu, click the Read button in the news-
group window Toolbar, or press Enter.

The article will open and display in a window.

Figure 3-5

This window will be opened as a separate window from the newsgroup
window.

Reading Articles
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You can choose to have the newsgroup window change into the article
window.  In the <Options> dialog, accessed using Other in the Options
menu, choose Use Newsgroup window to read article instead of the default,
Open New window to read article. Reading articles in a separate window is a
matter of personal preference; there are no great advantages or disadvan-
tages to either method. Reading articles in a separate window allows you to
examine both the article as well as the article list at the same time. Reading
in the same window is more efficient, because it decreases the number of
windows on your desktop and your windows can be larger.

You can read through the article using the Windows scroll bars at the edge
of the screen or any of the standard Windows movement keys: Page Up,
Page Down, the arrow keys, Home and End.

You can specify which header information (i.e. Newsgroups:, From:, To:)
can be displayed in this screen; see “Displaying and Sorting News Articles”
for more information.

When you are reading an article in News you have several options:  you
can save the article to a file, print the article, or copy information from the
article to other Windows programs.  You can also post a follow up article
on the same subject, or reply (send a mail message) to the person who
posted the article.

When you are done reading the article, you can do any of the following:

• Click the Back button to return to the article screen or press the Esc
key

• Click >> to move to the next article in the article screen (the article
below the current article)

• Click << to move to the previous article in the article screen (the
article above the current article)

• Doubleclick the Windows system menu to close the article (and
newsgroup, if you are viewing in Read In Place” mode).

READING ARTICLES ENCODED WITH ROT13
Some articles in News contain somewhat questionable material. In order to
avoid offending readers caught off guard, text is sometimes ‘scrambled’
using ROT13 message coding, which shifts each character 13 characters
(an ‘a’ becomes an ‘n’, etc.).  SPRY News includes a ROT13 coder/decoder.
To use this feature, highlight the text (it can be all or just some of a news
posting) and select ROT13 from the Edit menu.

Reading Articles
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ENCODING ARTICLES WITH ROT13
Encoding articles with ROT13 is done the same way you would read
articles encoded with ROT13: highlight the text in the posting window
that you would like to encode), and select ROT13 from the Edit menu.

CATCHING UP

News includes a Catchup command that allows you to “catchup” in a
newsgroup, marking all of the articles as “read” and hiding them from the
display.  The Catchup feature is used so that you don’t have to read
through articles that you’ve already read; in cases of newsgroups with many
hundreds of articles, you may wish to use this feature so that you can start
“from scratch” to try to keep up with the volume of articles that are created
every day.

To catchup a newsgroup, have the newsgroup article screen open, and click
the Catchup button on the article screen Toolbar, or click Catchup in the
Newsgroup menu. You will be asked to confirm that you want to catchup.
The newsgroup you are currently reading will close; you are caught up.
The newsgroup is now “empty” (although the articles can be re-displayed);
the next article(s) posted to that newsgroup after you use Catchup will
appear at the beginning of that newsgroup.

If you try to open a caught up newsgroup, and no new articles have been
added to the newsgroup, you will be presented with a dialog that informs
you that you are caught up in that newsgroup, and asks you if you want to
open it anyway.  If you open the newsgroup anyway, the newsgroup will
display as empty.

If you catchup a newsgroup, and decide that you do, after all, want to see
those older articles, you can click Show All Articles in the Newsgroup
menu to display all of the articles that were hidden using the Catchup
command.

You can, if you wish, turn off the Confirmation dialogs that appear when
using Catchup or trying to open a caught up dialog.  In the <Other>
dialog (accessed using Other in the Options menu), uncheck Confirm on
Catchup or Confirm on open of caught up Newsgroup.

Reading Articles
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DISPLAYING AND SORTING NEWS ARTICLES
You can change the font used in your News screen, how articles are sorted
in the Article window, and what header information is displayed.  This
section describes these options.

SETTING THE NEWS FONT

You can choose Font in the Options menu to change the news display text
to different fonts, sizes and styles.  The News screen will resize after you
change fonts.

You can change the font for the News listings (newsgroups and articles) or
for the article screens.  You can only choose fixed fonts (such as Courier)
for the article screen.  To change these fonts, select the Font command
when in either view.  A Windows font dialog will appear allowing you to
choose the font, font style, and font size to use when displaying lists or
articles.

SORTING ARTICLES

When you are viewing an article in an article window, the details about
those articles, the Author, Date, number of Lines, and Subject, are dis-
played in a detail fieldbar.  (If you are sorting articles using threading,
discussed in the “Threading” section, no fieldbar will display).

Figure 3-6

You can click on the Author, Date, Lines, or Subject portion of the
fieldbar to sort the articles using that detail.  (You can also choose the
corresponding Sort by... option in the View menu.)  A check mark will
appear next to the sort method you have chosen

You can change the width of any of these fields by moving the cursor to the
dividing line between the fields on the fieldbar; the cursor will change to a
double-headed arrow, and you can widen or narrow the fields.

By default, news articles are sorted in Ascending order, as follows:

From: alphabetical, a-z
Date:  oldest to newest

Lines:  smallest to largest

Subject: alphabetical, a-z.

Displaying and Sorting News Articles
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You can change the order in which the articles are sorted, from Ascending
to Descending.  The View menu will display the sort order being used for
the detail you are sorting on; to change it, select that option in the View
menu.

Another option for sorting is listed in the View menu; you can sort by
Thread.  Threading is discussed in the next section.

DISPLAYING HEADER INFORMATION

News allows you to specify which news article header information to
display.  This is information such as the news subject, author, newsgroups
the article is posted to.

By default, all the header information will be displayed.

Figure 3-7

The information you see may vary according to the news program/host
being used by the person posting the article.

You may not want to display the entire news header; you can decide which
information you really want to see, and specify that just that information
be displayed.

Click Message Headers to display the <Article Headers> dialog.

Figure 3-8

Displaying and Sorting News Articles
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The selection All (display all header information) is checked on, by default.
You can select None to display no header information (unless you think
you can tell who sent you mail by the content of their message, this option
may not be helpful).

To select which message headers you want to display, choose Selection:.
You will then be able to click on the items you want to display in the
message header.

Figure 3-9

If you are not sure which items you will need, look at some of the messages
you’ve received to determine what information you find useful.  The names
of the items in the Selection field above should be the same (or very
similar) to the actual header information you see.

When you have chosen the items you want to display, click OK.

You will then see new headers on all news articles, displaying just the
information you specified.

Figure 3-10

Displaying and Sorting News Articles
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REFRESHING NEWSGROUPS AND ARTICLES
In USENET news, new newsgroups often appear and disappear; older
articles expire and new ones are continually added.  Because it takes some
time to read in newsgroup and article information, you have the option of
“refreshing” (updating) the newsgroup and article screens whenever you
wish.  When you refresh the screen, any changes that have occurred will be
updated; if you do not, you may find that you cannot open some (deleted)
newsgroups, or that you don’t see new articles in a newsgroup.

You can refresh the current newsgroup screen (Newsgroup Browser or
Personal Group) or article screen by choosing Refresh from the Newsgroup
menu.

If you want to refresh all screens upon opening, check Auto Refresh to
automatically refresh the newsgroup listing when opening.  This process
takes a little while (you will see a “Refreshing listbox” message in your
Status Bar) but ensures that the news listings you see are accurate.  How-
ever, if you would prefer to list newsgroups faster, you can disable this
option by unchecking it; this will lessen the time it takes to re-list all the
newsgroups.  (Note:  Newsgroup articles will automatically be refreshed
when you open them).

You can choose Refresh from the Newsgroup menu at any time to refresh
newsgroups in the window you have selected.

Refreshing Newsgroups and Articles
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USING THREADING
When you’re reading USENET news, you will notice that many of the
posted articles are responses to previously posted articles, and many are
responses to those responses.  News keeps track of which articles are related
to which others.  Threading is a method that can be used to group those
articles together, so that you can follow the sequence (the “thread”) of an
entire news conversation.  News supports threading with an easy-to-use
graphical interface.

Click Sort by Thread in the View menu to change the current display to
show articles sorted by thread.

Figure 3-11

Articles will be listed first in alphabetical order, and then will be listed by
thread.  The first article in a thread (the “root” article) will be an article to
which follow up articles were posted.  The follow up articles are considered
part of the thread, and are listed under the root article in a tree structure.
Note:  the root article is not necessarily the first article ever posted about
that particular subject; the original root of the thread may have expired
already.

In a thread, there can be follow up articles to the root article, or there can
be follow-ups to those follow-ups (it can get quite complex).  Thread links
are shown in color to help you identify which article an article was follow-
ing up to; the first level is black, the second blue, the third red, etc.

You can read an article in a thread as you would a normally displayed
article.  You can then click >> in the article screen Toolbar to move to the
next article that thread.  If you click >> when the thread is finished, you
will move to the next thread.  Likewise, clicking << will move you to the
previous article in the thread, and then the previous thread.

Using Threading
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When you are displaying articles by thread, you will not see all of the
information about the article listed on each line as you do in other
displays; you will only see the subject of the root article, and the author of
each follow up article.  If you highlight an article, however, you will see
additional information listed in the Status Bar at the bottom of the screen.
This was done to keep the screen manageable (since all of the subjects of
the thread are usually the same).

You can collapse or expand specific threads.  Collapsing an article thread
hides all the follow-ups to that article, allowing you to ignore threads you’re
not interested in.  When you collapse a thread, a small triangle indicator
below the article name reminds you that there are connected articles
underneath.

Expanding will display any collapsed articles under a thread.

Figure 3-12

Highlight the top of the thread that you want to collapse, and click
Collapse in the article screen Toolbar to hide all the connected threads.  To
expand them again, doubleclick on the article name, or click Expand in the
article screen Toolbar.   If you want to expand all threads quickly, click
Show All Articles in the Newsgroup menu.

By default, all threads are expanded fully when you use Sort by Threading;
if you want threads to stay collapsed until you open them, change the
Open all Threads Initially option in the <Other> dialog (accessed using
Other in the Option menu).

Using Threading
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SAVING ARTICLES
You can save any currently displayed article to a text file using the Save
command. You will be prompted to Append or Overwrite the file if it
already exists.

SAVING AN ARTICLE TO A FILE:

1) Open the article.

2) Choose Save As from the File menu

or

Click the Save button on the Toolbar.

You will be asked to specify a filename for the article.  The News program
will suggest an extension of .txt.  Type a name, and click OK or press
[Enter].  The article will be saved to the filename you specified.



3-20

PRINTING ARTICLES
You can print any currently displayed article by using the Print command.
The article will print to the default printer currently being used by Win-
dows.  If you want to change the printer that is used, you must change the
default Windows printer in Windows Control Panel (see your Windows
manual for more information).

PRINTING AN ARTICLE:

1) Open the article.

2) Choose Print from the File menu

or

Click the Print button on the Toolbar.

The article will immediately print to the Windows printer.

The Print command is “context sensitive”; you can also use it while
displaying a list of articles or newsgroups.  The currently displayed screen
of articles or newsgroups will be printed to the default Windows printer.

Printing Articles
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COPYING INFORMATION FROM ARTICLES
You can copy information from a News article to other Windows applica-
tions by using the Copy command.  The information will be copied to the
Windows Clipboard.  You can then paste the information into another
Windows application (like Microsoft Word) by using that application’s
Paste command.

COPYING INFORMATION FROM A NEWS ARTICLE:
With the article open, highlight the text you want to copy with your
mouse and click Copy in the Edit menu (or press Ctrl-C).  The text will
be copied to the Windows Clipboard and will be immediately available to
Paste in any Windows application.

You can also copy information from any other Windows application and
paste it into News postings using the News Paste command.  See the
“Posting Articles” section for more information.

Copying Information from Articles
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FINDING ARTICLES
You can use the Find command in News to find text in newsgroup names
or in article headers.  Find will search the currently active newsgroup or
article window.

Click Find in the Options menu; the <Find> dialog will appear.

Figure 3-13

In the Find What field, type the text you want to find.  You can check
Match Case if you want to match the case of the text you typed (otherwise,
a case-insensitive search will occur).

Click the Find button to search; all the newsgroups or article headers that
match will be displayed in the Results: dialog.  You can go to any of the
located items by doubleclicking on the item name or by highlighting the
item and clicking Go To.

Finding Articles
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DECODING FILES IN NEWS ARTICLES
Some articles that you will find in News are not actually articles; people
will post shareware and freeware applications, graphics and sound files, and
other binary files that they want to share with other USENET News
readers.  These files are typically stored in newsgroups with the word
binaries in the name; i.e. comp.binaries.ibmpc, or comp.binaries.pictures.
Encoded postings are usually identified in the subject line as a program or
graphics file, with subjects like “program.exe, part 1 of 3”, “program.exe,
part 2 of 3”, “program.exe, part 3 of 3”.

Figure 3-14

When you look at an article which is an encoded binary file, it will contain
what looks like random ASCII characters (the article appears all garbled
and incomprehensible).  Since Internet News only supports posting ASCII
text, binary files must be uuencoded before they can be posted to articles.
This is a popular method used on the Internet to “convert” the binary file
to ASCII so that it can be posted on the Internet.  These articles can be
uudecoded so that you can convert them back to their original binary files.
News includes an automatic decoding feature which allows you to decode
and view files like this that you find in News.

To decode a uuencoded file, select any of the parts of the file and click on
the Decode button on the Toolbar or choose Decode from the Article
menu.  The <Save Decoded Articles> dialog appears, prompting you for a
location to save the files to.  Select the directory you wish to save your files
to after they are decoded.

Decoding Files in News Articles
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Figure 3-15

The <Save Decoded Articles> dialog box also has several other options you
can select, described below.

The Overwrite Existing Files option lets you determine the overwrite
preferences: Replace existing files, meaning files in the destination directory
will be replaced if a file with the same name is decoded; Skip existing files,
meaning a file will not be decoded if there is already a file with the same
name in the destination directory; and Ask before replacing, meaning News
will prompt you to confirm that you want to replace a file with a decoded
file of the same name.

You can also determine whether or not you would like to see the <Save
Decoded Articles> dialog during the decoding process.  You can avoid
being prompted for a destination directory during each decode by selecting
Skip this dialog.

If you select the ‘Skip this dialog’ option, News will save all decoded files to
the last-specified destination and never prompt you for a destination. If
you select this option, but later wish to change the destination directory,
you can access the <Save Decoded Articles> dialog box by choosing
Decoding... from the Options menu.

The Use status window option allows you to turn on or off the <Decoding
Status> dialog box described later in this section.

The View decoded files option allows you to have News try to open the
decoded file using the viewer associated with the decoded file type.  A
viewer is an application used to open and view a file.  For instance,
ImageView, which is included with your SPRY applications, will open and
view graphics files such as GIF and JPEG, popular Internet formats.  (For
more information on ImageView, see the ImageView chapter.)  When you
have the View decoded files option selected, and you decode a file whose
type is associated with ImageView, News will try to open the file by
starting ImageView, opening the decoded file, and making ImageView the
active application in Windows.

Decoding Files in News Articles
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In other words, with the View decoded files option, you can select a file,
click on the Decode button, and in an instant, you can view it in its
associated viewer.

If you have sound or video applications on your system, you can associate
them with their respective file types in File Manager, and News can
automatically start the viewer and open the file.  See your Microsoft
Windows documentation for more information on associating files in File
Manager.

If you wish to have News try to open the decoded file using the associated
viewer application, you should deselect the Show status window option;
when this option is selected, the <Decoding Status> window (explained
below) will remain the active window after decoding, and News will not
automatically switch to the associated viewer, requiring you to manually
switch from News to the viewer application.

News will only open the first viewer associated with a file.  For instance, if
you decode a zipped JPEG file (a JPEG file with a .zip extension) and the
.zip file type is associated in File Manager, News will launch the associated
application, which will then allow you to unzip the file.  News will not,
however, then open that file in its associated viewer (i.e. a JPEG file that
has been zipped will not be unzipped and opened in ImageView).

IF YOU HAVE DIFFICULTY DECODING AN ARTICLE IN NEWS
The <Decoding Status> dialog box displays information on the current
decoding session; this dialog box can be useful for troubleshooting and
tracking the decoding process.

Figure 3-16

Decoding Files in News Articles
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By highlighting message text in the <Decoding Status> dialog box and
clicking on the Copy button, you can copy and paste status messages. This
feature is useful for discussing decoding problems with the creator of a file.
Clicking on the Clear button will clear all text from the dialog box.

A common error message you will encounter in the <Decoding Status>
dialog box will be “ERROR: Files missing.”  This will occur when portions
of an encoded file are missing (not present in the newsgroup).  There is no
solution to this issue, but you could reply to the posting and ask the
creator to repost the missing files.

Another common error will read: ERROR: no viewer for xxxxxx, where
xxxxxx is the path and filename of the encoded file you tried to decode.  If
you receive this error, you don’t have a viewer associated with the file type.
The viewer may be present on your system, but you still need to associate it
in Windows File Manager.  See your Microsoft Windows documentation
for more information on associating file types in File Manager.

You will see more error messages than those listed above.  They have been
designed to be logical and easy to troubleshoot.  Most often, the errors you
encounter while decoding a file cannot be resolved without asking the
creator of the file to repost the file.

The subject line for a series of encoded articles must contain information
specifying that the file is part of a series: either “xxxx” 1/5 “xxxxx” or “xxxx
3 of 5 xxxxxx”, where xxxx is extraneous file information (title, etc). Also,
in order for the auto-decode feature to work, the extraneous information
must match for each file in a series; otherwise, SPRY News will not
consider the files part of the same series.

Decoding Files in News Articles
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POSTING ARTICLES
You can post your own articles to a newsgroup if the newsgroup will permit
it, and you have rights to post articles on that news server.

It is recommended that you familiarize yourself with USENET news before
making any posts.  USENET has its own particular guidelines and “eti-
quette” which can be mystifying at first.  A good newsgroup to read and
post questions to is the news.newusers.questions newsgroup.  There is also
often a test group that is designed for test posts; when you are starting to
learn how to post you may want to post to the test group in your area; i.e.
seattle.test or ny.test.

If you are posting an article in response to another article, you should use
the Follow Up command.  See the next section for more information on
Follow Up.

POSTING AN ARTICLE TO A NEWSGROUP:

1) Select the newsgroup you wish to post an article to by highlighting the
newsgroup or reading one of the articles in that newsgroup.

2) Choose Post from the Article menu or Click the Post button on the
Toolbar.

You will see the <Post Article> screen.

Figure 3-17

3) Type your article, using the standard Windows editing keys to move
around the screen:  Page Up, Page Down, the arrow keys, Home and
End.

Posting Articles
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You can paste text into your article from another news article or from
another Windows application.  You must use the cut or copy command
in the other article screen or application, and then click Paste in the Edit
menu to paste the information at the cursor position.

You can also cut or copy any of the text you type in this article screen
using the Cut and Copy commands in the Edit menu.  The text can
then be pasted into other Windows applications using those applications’
Paste command.

You can also attach binary and text files to your article; see the section on
attaching files, below.

4) Fill out the header information by clicking the Header button on the
article screen Toolbar.  The news header screen will appear.  This
contains the information that is used to post the article.

Figure 3-18

Fill out the Subject: field.  (This is very important.)  If you are posting a
Follow Up article, the Subject field will be filled out for you; in this case,
it is recommended that you not change this field, as it will help other
people reading news follow the news article threads (see “Using Thread-
ing in News” for more information).

The From: field specifies your return address.  You can specify your mail
address, along with a “nickname”, if desired.  Use one of these sample
formats: rapunzel@castle.com (Rap), “Rap” rapunzel@castle.com, or
Rap <rapunzel@castle.com>, where Rap is your nickname.

Some of these fields can be filled out automatically for you by News.
Choose Signature from the Options menu to customize these fields;
they will then automatically appear when you post your article.

Posting an Article
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5) Click Send to post the article, or doubleclick the Windows System menu
in the upper left hand corner of the screen to close this screen without
sending the article.

There is no way to revoke or delete an article you’ve posted, so be
sure your article is complete before posting!

ATTACHING FILES TO AN ARTICLE
You can insert (“attach”) a binary file (such as a spreadsheet, word process-
ing or graphics file) to your news article (or mail reply).  You can also have
News automatically attach a text file (a “signature” file) to every news
article or mail message you create.  These options are described below.

ATTACHING A BINARY FILE TO AN ARTICLE:
News automatically converts binary files to a format that allows them to be
posted in a News Article.  This process is called uuencoding the file.  The
reader of the news article must have a uudecode program (a popular file
decoding method) in order to convert the file back to its original format.

You can attach a small file to your News posting without having to
do any special conversion.  However, News articles have a size limit
of 64K.  If the file you want to post is larger than 64K, you will have
to use a UUencoding program to split the file into multiple parts;
you will then have to post each of the parts of the file to the news-
group.

1) In the <Post Article>, <Follow up>, or <Reply> screen, click the Show
Attachment button.  An empty window will appear below your article.

Figure 3-19

Posting an Article



3-30

2) Click the Attach button.  You will see an <Attach File> dialog that you
can use to navigate your directories and choose a file to attach.   Select
the desired drive and directory and the filename that you want to attach.

You will see an icon appear for the file you attached. (You can choose
Remove to remove an attached file.)

3) When you have finished attaching the file, choose Hide Attachment to
return to your posting screen, if desired.  You can post the article as you
would normally, by pressing the Send button.  When you choose Send,
News will begin attaching the file to the posting.  If the file is a text file,
it should be attached quickly.  If it is a binary file, it may take some time
to attach the file, as it has to go through the uuencoding process (as
described above).  When the file is attached, the news article will imme-
diately be posted.

AUTOMATICALLY ATTACHING A TEXT FILE TO AN ARTICLE:
It is very common for news postings to contain a signature; some text at the
end of the article that the author chooses to include in every article they
post.  Signatures range from the formal to the goofy; containing address
information, quotes, trivia, fun Internet links, etc.  They usually range
from 1 to 5 lines.

You can create your own News signature, if you like.  This is known as an
Auto Attach file; it is automatically attached to every news article you post
(or e-mail reply you send).  If you are a SPRY Mail user, News will, by
default, use your Mail Auto signature file in News.

1) If you do not yet have a file to use as your auto attach file, create the file
using a text editor.

2) Click Other in the Options menu.

3) For the Auto Attach value, specify the name and path for the auto attach
file.  You can click Browse to browse your directory for this file, if
necessary.

4) Click OK.  The Auto Attach file will be used the next time you post an
article (or send a Follow Up or e-mail reply).

Posting an Article
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FOLLOWING UP AN ARTICLE
Following up an article is almost the same as posting a new article, except
that the Subject of your article will reference the article you are currently
reading, and the text of that article will be included in your posting.  Your
news article is also “linked” to the original article, so that it will display as a
follow up to that article when a news reader is displaying articles in
“thread” mode.

FOLLOWING UP AN ARTICLE:

1) Open the article.

2) Choose Follow up from the Article menu

or

Click the Follow up button on the Toolbar.

3) The article you are following up will be included in the <Follow Up>
screen; you can remove some or all of the article, if you’d like.  Type
your article in this screen.  You can use standard Windows movement
keys, like the cursor keys, Page Up and Page Down, to move around the
screen.

You can copy and paste information to and from this article, and, if you
wish, Attach files to the article.  (See the “Posting Articles” section for
more information on copy and paste and attaching files).

4) Click Send to send this follow up article, or double-click the Windows
System menu in the upper left hand corner of the screen to close this
screen without sending the article.

Following Up  an Article
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REPLYING TO AN ARTICLE
You can send an e-mail reply to the person who posted an article you’ve
read.    This works just as if you were sending e-mail directly to the sender;
you can add additional people to the addressee list (To: or CC: field), and
change the subject line before sending the reply.

REPLYING TO AN ARTICLE:

1) Open or select the article.

2) Choose Reply from the Article menu

or

Click the Reply button on the Toolbar.

A reply screen will appear, addressed to the author of the article you
selected, with the same subject as the news article.  Change this header
information, if desired.

3) Type your message in this screen.  You can use standard Windows
movement keys in this screen, like the cursor keys, Page Up and Page
Down to move around the screen.

You can cut, copy and paste information to and from this message, and,
if you wish, attach files to the article.  (See the “Posting Articles” section
for more information.)

4) Click Send to send this reply, or doubleclick the Windows System menu
in the upper left hand corner of the screen to close this screen without
sending the reply.

The article will be mailed to the person/people you indicated.

Replying to an Article
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USING PERSONAL GROUPS
Due to the large numbers of available newsgroups (varying according to
which news server you’re attached to), it can be time consuming to wade
through thousands of newsgroups just to read a selected group.  News
allows you to save different lists of newsgroups to Personal Groups so that
you only access the groups you want to see.  Some sample Personal Groups
are included with News; you can create your own Personal Groups, group-
ing newsgroups in any way you like.

Personal Groups are different from the newsgroup browser; each news-
group in a personal group contains additional information such as a book
icon (indicating whether the newsgroup has been opened), the newsgroup
name, and the number of articles in that newsgroup.  Note: the number of
articles is computed from the difference between the first article number
and the last; due to deleted articles, this number may not be completely
accurate.

CREATING A NEW PERSONAL GROUP

1) Click Personal Group in the Window menu. You will see the <Open
Personal Group> dialog.

Figure 3-20

2) Click the New button to create a new personal group.

 You will see the <Newsgroup Properties> screen.

Figure 3-21

Using Personal Groups
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3) There are two items you can specify in this dialog, Description and
Filename.  You should specify a name for the Personal Group in the
Description field.  This can be any name you choose.

The Filename is optional; use this if you want to use a Personal Group
that already exists.  The filename for the Personal Group must be eight
characters or less and contain no spaces (or characters illegal in DOS
filenames).

4) Click OK to create the new Personal Group.

ADDING NEWSGROUPS TO A PERSONAL GROUP

You can add newsgroups to a Personal Group using the Newsgroup
Browser.  You can Subscribe newsgroups to a Personal Group, or drag and
drop them into the personal group.

If the Personal Group is already open, it is easiest just to drag and drop the
newsgroup(s) into the Personal Group:

1) Select one or more newsgroups (use Shift when highlighting to highlight
a series of newsgroups, or use Control when highlighting to choose
nonconsecutive newsgroups).

2) Drag and drop the newsgroup(s) into the Personal Group.

If the Personal Group you want to add the articles to is not yet open (or
not yet created), it is easiest to use the Subscribe command:

1) Select one or more newsgroups (use Shift to highlight a series of news-
groups, or use Control to choose nonconsecutive newsgroups).

2) Click Subscribe in the Newsgroup menu.

The <Open Personal Group> dialog box will be displayed.  You should
specify the Personal Group to which you want to add the highlighted
newsgroup(s).

Figure 3-22

Using Personal Groups
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OPENING PERSONAL GROUPS

Once you have created Personal Groups, you can open them at any time
from the <Open Personal Groups> dialog by highlighting the Personal
Group name and clicking OK.  The Personal Group will open in the News
Console.  You can then read any newsgroups in it.  You can also add and
remove newsgroups from it, as described below.

AUTOMATICALLY OPENING PERSONAL GROUPS
You can open one or more Personal Groups automatically when you start
News.  Open those Personal Groups on your screen, and check the Save
workspace on exit option in the Options menu.  When you exit and re-
open News, the Personal Groups will open automatically.

Using Personal Groups
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UNSUBSCRIBING NEWSGROUPS

If you want to remove newsgroups from your Personal Group, you can
unsubscribe them, as described below.

UNSUBSCRIBING A NEWSGROUP:

1) Select one or more newsgroups to unsubscribe by clicking on the news-
group name(s) with your mouse to highlight it (them).  You can select
multiple newsgroups by using the standard Windows selection keys.
Holding down [Shift] while clicking on newsgroups will select a series of
newsgroups.  Holding down [Ctrl] while clicking on newsgroups will
select multiple newsgroups.

2) When you have chosen the newsgroups you want to unsubscribe to:

Choose Unsubscribe from the Newsgroup menu

or

Click the Unsubscribe button on the Toolbar.

The newsgroups you have unsubscribed to will be removed from the
current Personal Group.

CHANGING OR REMOVING A PERSONAL GROUP

You can change the location or description of a Personal Group by choos-
ing Properties in the <Open Personal Group> dialog, and typing the new
information.

In this dialog, you can also remove a Personal Group by highlighting the
Personal Group name and choosing Delete.  This will permanently delete
the Personal Group.

Replying to an Article
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CHANGING THE STARTUP NEWS SERVER
News will connect to a default News Server whenever you startup News.
You can specify a different News Server to connect to by default by choos-
ing Startup in the Options menu; the <Startup Options> dialog will
appear, displaying the News Server that News is setup to connect to
automatically.

Figure 3-23

Click Add to add another News Server address.  This can be an IP address
(such as 165.121.6.30) or fully qualified domain name (such as
news.service.net).

News will store the name of the News Server you choose so that you can
automatically connect to it in the future.

In this dialog, you can also set up whether News should automatically
connect to the selected News Server on startup.  If you use more than one
news server, you may want to use this setting.  Uncheck Restore Connection
at Startup to not connect to any News Server on startup.

If you use this option, you will need to connect to the News Server after
starting News by choosing Open Connection from the File menu and
specifying a News Server. You must close any active News connections
before you will be able to open a new connection, or you can use the
Change Server option described in the next section.

You can disconnect from a News Server at any time by choosing Discon-
nect from the File menu.

Changing the Startup News Server
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CHANGING NEWS SERVERS DURING YOUR NEWS SESSION
You can connect to a different News Server during your News session by
selecting the Change Server option from the File menu. This will bring up
the <Change Server> dialog.

Figure 3-24

Enter the News Server address you want to switch to.  To add this address
permanently to the list, click on the Add button.  To switch to the new
News Server, check Connect Now and click OK. Your server connection will
change, and you will be connected to the new server.

Unless you have subscribed to a News Server, you probably won’t be able to
connect to it.  To gain access to a News Server other than the default,
contact that News Server’s System Administrator.

Changing News Servers During Your News Session



Chapter 4
SPRY Network File Manager

Network File Manager™ (NFM) was developed as an enhancement to
traditional ftp-based file transfer programs.  The term ftp is a UNIX term
referring to a protocol that is used to copy files to and from UNIX hosts.
The Network File Manager can be used to transfer files between your PC
and an ftp site (also referred to as ftp server).

Network File Manager works with the Windows File Manager; drag and
drop files directly from an ftp site to your Windows “desktop”, and vice
versa.

Please note that NFM supports only procedures and file listings that
are supported on the ftp server you’re connected to.

NETWORK FILE MANAGER FEATURES
• Drag and drop file transfer between an ftp server and Windows File

Manager or between two remote ftp servers.

• Move, copy, delete, and rename files and directories on a remote ftp
server (if you have rights to do so).

• Use the familiar Windows File Manager style interface to view, sort,
and manipulate files.

• Connect to multiple hosts at once.

• Automatically reconnect to one or more hosts at startup.

• Allows you to save complete connection information for your
session.

• Set up default login, password, and connection information.

• Save window positions, fonts, and other settings.

• Edit NFM connection information:  username, password, account
number, host type, and advanced connection options.

• Support for many host types, including NetWare, VMS, VM, MVS,
and Windows NT.  NFM can also automatically detect host types.

• Support for Firewalls (currently, only ANS firewalls are supported).

• Log ftp session activity to screen or file.
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NETWORK FILE MANAGER REQUIREMENTS
• The Microsoft Windows 3.1 File Manager program is required to

use the drag and drop file transfer capabilities of the Network File
Manager.
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STARTING THE NETWORK FILE MANAGER
You start the Network File Manager (NFM) by clicking on the NFM icon.
You will see a <Connect To>* dialog asking you to login to a host.

Figure 4-1

* If you have NFM set up to automatically reconnect you to each host you were connected to in
your last NFM session, a <Reconnect To> dialog may appear before the <Connect To> dialog.
See “NFM Startup Options” for more information on this reconnect option.

You are prompted for a connection name (optional), a host to connect to, a
host type, username, password, and account.    These options are described
below.

Connection (Optional):
You can save connection information for hosts that you connect to,
including the host, username, password, host type, and account, as well as
advanced connection information like the port and logging files you want
to use.

You can specify connections for each host you connect to (or save multiple
connections for the same host) so that you can easily reconnect to that host
without having to specify the information again.  Any connections you
create will appear in the drop down Connection: list.  You can then select
them from that list, and the <Connect To> dialog will be filled out with
the information you specified.

TO CREATE A NEW CONNECTION:
Specify any name you choose for the connection.  You can use spaces, and
use a logical name like “Microsoft FTP site” or “Gwen’s Machine”.  Con-
nection names cannot exceed 64 characters.  You should then fill out the
rest of the dialog.  Checking the Auto Save to Connection List checkbox at
the bottom of the dialog will save your connection automatically.

Starting the Network File Manager
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TO CHOOSE AN EXISTING CONNECTION:
Select a connection from the drop down list.  The connection information
you previously saved should appear in the dialog; if you need to supply
additional information, you should fill it out.

You can add, modify, or delete Connections using NFM’s Edit Connec-
tion List feature.  See “Configuring Connection Options” for more
information.

Host (Required):
Specify the address for the ftp host you will be connecting to.  You can
specify a host by its IP address (such as 165.121.6.65) or its Fully Qualified
Domain Name (FQDN) (such as mycroft.bakerstreet.com).  Type the IP
address or FQDN in the hosts field.

Host Type:
Host type indicates the file format for the FTP host you are connecting to.
FTP is set up to Auto Detect the host type; it will try to detect the file
format of the remote host and display files accordingly.  In most cases, you
should leave the Host Type: field set at Auto Detect.  If NFM has trouble
displaying all the file information for files on the remote host, and you
know the host type for the remote host, you should select that host type
from the list, and try reconnecting.  If you are unsure of the host type, and
Auto Detect does not work, choose Generic.

User Name (Required):
Specify your username (login name) on the ftp host you have specified.

If you are connecting to an anonymous ftp site (a publicly accessible ftp site) on
the Internet, you will usually be asked to specify a login name of anonymous
with your e-mail address as your password  (i.e. lucy@narnia.com).

Password (Required):
For Password:, specify your password on the ftp host.  You must specify a
password; if none is required on the host you are connecting to, type in a
few random characters.

As mentioned above, anonymous ftp sites usually require you to supply
your e-mail address as a password.

Starting the Network File Manager
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Account (Optional):
Some ftp hosts require an account number.  If this is the case, fill out the
account number in this field; it will be passed to the host.

Auto Save to Connection List
You can have NFM save a connection to the Connection List automatically
by checking this option.  If you select this option, you will have to specify
a connection name in the Connection: field (see the description of Connec-
tion, above).  If you have this option checked when you specify a new
connection, it will automatically be saved to your Connection List.  If you
have this option checked and make changes to a connection you have
already defined, those changes will be saved and will replace the old
connection information.

If you do not have this option checked, but specify a new connection name
for your NFM session, NFM will ask you if you want to save the new
connection to the connection list.  In most cases, you will probably want to
save connections, since it makes reconnecting to a host easy.

You can have default information fill automatically in this dialog when
connecting to any host; see “Specifying Default Connection Information”
later in this chapter for more information.

Once you have typed in the required information, click OK

Advanced options are also available in this dialog; you can click the
Advanced button to specify advanced connection options for your session.
These options are described in “Configuring Connection Options” later in
this chapter.

Starting the Network File Manager
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WHEN YOU CONNECT

You will start connecting to the FTP server you specified.  The Status Bar
at the bottom of the NFM Console will display Connecting to <hostname>.
If a connection is made, the Network File Manager will bring up a direc-
tory window displaying the files on that host.

You can immediately begin transferring files; see “Working with Files in
NFM” for information on file transfer and other operations.

IF YOU CAN’T CONNECT
When you are connecting to ftp sites on the Internet, you may run into
situations like the following:

• FTP sites may sometimes be unavailable due to system down time or
technical problems.

• Some hosts on the Internet will not permit anonymous FTP or
require you to be an authorized user on their host.

• Anonymous ftp sites often carry restrictions on the number of users
that can connect during prime-time (i.e. workday) hours.

In most cases, NFM will alert you to the particular problem by showing
you an alert message when you try to connect to the host.  However, due
to the number of different ftp host types on the Internet, NFM is not
always able to filter these messages correctly.  If you are unable to connect
to an NFM host, and do not see a message indicating the problem, you
may want to log your session activity to a file;  see the description of
logging options in the “Configuring Connection Options” section later in
this chapter.

OPENING MULTIPLE NFM SESSIONS

Once you’ve opened an NFM session, you can continue to open other
NFM sessions.  Choose New Connection from the Window menu or click
the Connect button on the Toolbar.  You will see the <Connect To> dialog,
and can log in to another session.

If you have several NFM sessions open, you can change the way the session
windows are displayed.  The Cascade command in the Window menu will
cascade all open NFM windows (windows are stacked on top of one
another), and the Tile command in the Window menu will automatically
tile all open NFM windows (windows are displayed side by side).

Starting the Network File Manager



4-7
NFM

You can also minimize NFM sessions by choosing Minimize from the
Microsoft Windows System Menu, and specify Arrange Icons to arrange
any minimized NFM icons so that they are evenly spaced and do not
overlap.

CLOSING NFM SESSIONS AND EXITING NFM
You can close all of your NFM sessions and keep NFM open; note that
many menu options and dialogs will be unavailable when you are not
connected to a host.

You can completely exit the Network File Manager by choosing Exit from
the File menu or by doubleclicking the Windows System menu in the
upper left hand corner of the NFM Console.  This will close all open NFM
sessions.

Starting the Network File Manager
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THE NFM CONSOLE
The first time you start the Network File Manager, the Network File
Manager and Windows File Manager will both be opened.

Figure 4-2

You can tile the two windows horizontally (Windows File Manager on top,
NFM on bottom) by choosing Tile FM and NFM Horizontally in the
Window menu (or by pressing F6) or tile the Windows File Manager and
NFM vertically (on top of one another) by choosing Tile FM and NFM
Vertically in the Window menu (or pressing Alt-F6).

If you do not want to open the Windows File Manager automatically, you
can uncheck Start File Manager at Startup in the <Startup Options>
dialog, accessed by choosing Startup in the Options menu.

The Status Bar at the bottom of the NFM Console displays information
on the current status of NFM operations, like connecting to a host or
copying a file.  The Toolbar at the top of the NFM Console has buttons
displaying frequently used commands. You can see the meaning of a
Toolbar button by moving your mouse on top of it; the Status Bar will
display the function of the button.  You can display the Toolbar as Picture
only, Text only, or Both Picture and Text, by choosing Toolbar Style in the
Options menu.

Both the Toolbar and the Status Bar can be hidden by unchecking Show
Toolbar and Show Status Bar in the Options menu.  The Toolbar and
Status Bar will be displayed if checked.

You can also change the font that is used in the NFM Console by choosing
Font in the Options menu.  A Windows font dialog box will appear; select
the font you want to use, and click OK.

The NFM Console
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WORKING WITH FILES IN NFM
Once the Network File Manager is open and connected to a remote host,
you can begin copying/moving files between your PC and that remote
host, or between two remote hosts.  You can also perform other file opera-
tions like creating directories and renaming and deleting files/directories.
This section explains basic file operations in NFM.

You can only perform file operations that you have rights to per-
form, or that the FTP server you are connected to supports.  Some
systems will not allow you to move files or create directories.  (On
anonymous FTP Servers, you will typically only have rights to copy
files from that server to your PC).

Operations in the Network File Manager are very similar to operations in
the Windows File Manager:

• You can view the files or directories inside a directory by double-
clicking on the directory folder.  You can also choose Open from the
File menu to open a directory folder.

• To move up to the previous directory level, click on the up arrow at
the top of the directory list.

• You can change directories by double-clicking on directory folders,
just as you would when using the File Manager.  Some host systems
do not support changing directories with a mouse.  In these cases,
you can use the Change Directory command in the File menu to
specify the name of the directory you want to change to.  This is also
a quick way to change directories if you know the full “pathname” of
the directory you want.  The next section explains how to specify
remote host files and directories in this and other NFM dialogs.

Working with Files in NFM
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SELECTING FILES AND DIRECTORIES

There are two ways to select files and directories for operations in NFM;
you can specify them by filename, or you can select them using your
mouse.  These two methods are described below.

SELECTING FILES/DIRECTORIES BY FILENAME:
Specifying file and directory names for a remote host is very similar to
specifying file and directory names on your local PC.

Files/directories on a host are denoted in NFM by a hostname, followed by
a colon.  They then use the path name syntax of the host system.  For
instance, a UNIX file from host bart.marge.com would be displayed in a
NFM dialog box as:

bart.marge.com:/home/files/myfile.txt

Note that UNIX files use the forward slash instead of the backslash to
denote subdirectories.

A DOS file is specified in the dialog with standard DOS filename syntax:

c:\files\filename.ext

The hostname used is based on the name or address you provided when you
started the NFM session.

For the above reason, it is important not to name any of your hosts
with a one character name, a-z, as these may also correspond to DOS
drive letters, and NFM could not then distinguish them from DOS
drives.

SELECTING FILES AND DIRECTORIES WITH YOUR MOUSE:
You can select a file or directory to operate on by clicking on the file or
directory name with your mouse.  You can also select multiple files by
clicking on them with your mouse while holding down the  [Ctrl] or
[Shift] keys.  [Shift] selects a series of adjacent files, while [Ctrl] allows you
to individually select a number of non-adjacent files.

When the files/directories are selected, you can then use File menu opera-
tions on them, or drag and drop them onto a remote host or your local PC

Working with Files in NFM
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(via Windows File Manager).  See the next section, “Copying and Moving
Files with NFM,” for more information.

When filling out the file operation dialogs, the Current Directory (the
currently selected or highlighted directory in NFM) is shown at the top of
the dialog.  If you do not specify a pathname for any files you are manipu-
lating, their origins or destinations will be assumed to be the currently
selected directory.  To simplify operations, select the file or directory you
want to operate on before choosing an NFM command.

COPYING AND MOVING FILES WITH NFM
The Network File Manager supports copying and moving files:

• From your PC to an NFM host.

• From an NFM host to your PC.

• From one NFM host to another NFM host.

You can copy and move files either by dragging and dropping them or by
using the File menu Copy or Move commands and specifying the file
names and locations.

NFM does not permit you to copy or move entire directories.

You may want to customize your method of file transfer to the task you
have to do.  Drag and drop is useful for moving many adjacent files or
selecting files with nothing in common.  It also permits you to move files
without having to know the entire file pathname.  Using Copy and Move
from the File menu is useful when you want to specify a group of files with
similar names (using wildcard techniques), all of the files in a large direc-
tory, or when you want to copy or move files that aren’t currently displayed
on your screen.

SETTING THE FILE TRANSFER METHOD
You should make sure that the correct file transfer method is set before
transferring files with NFM.  You can transfer files using Binary or ASCII
file transfer.  You should use ASCII when transferring ASCII text files (like
files produced with Windows Notepad), and Binary when transferring
binary files (non-text files, such as executable files, graphics files, or sound
files).  If a file contains special “control codes,” (like a word processing
document, graphics file, or a sound file) it should be transferred as Binary.
You can specify the default file transfer mode to use by choosing this
option.  In most cases, you will probably want to leave this option as
Binary, since you will probably mostly be transferring binary files.

Working with Files in NFM
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You can easily change this option during an NFM session by clicking on
the ASCII and Binary buttons on the NFM Toolbar.

Click the Binary or ASCII button on the Toolbar before transferring files.

Since it is sometimes difficult to know before you transfer files what file
transfer method to use, you may want to select Binary for most file trans-
fers, and choose to examine text files using the Open command.  See
“Displaying and Printing Remote Host Files” for more information.

SETTING THE FILENAME TRANSLATION OPTION
You can specify whether files that are transferred are automatically renamed
by NFM.  Often, remote files have names longer than DOS allows (DOS
allows up to eight characters with a three character extension).  A long file
name (example:  tcp.ip.intro.txt) is automatically translated by NFM into a
legal DOS filename by using up to eight characters of the filename, and
adding an extension, if one was provided.  (In the example, the file would
become tcpipint.txt).

Checking Confirm Filename Translation on means that you will always be
prompted whether to change the filename using this conversion method.

When this option is checked on, and you copy or move one or more files
with long filenames, you will see a <Confirm Filename Translation Dia-
log>.

Figure 4-3

This dialog suggests a default filename for a file with a long filename.
Select Yes to accept the provided filename, or  change the filename to one
you prefer before selecting Yes.  Select No if you do not want to copy or
move the file at the current time.  If you are copying or moving several
files, you will be prompted to accept filenames for each filename; you can
select Yes to All to accept the default filenames for all long files in your
copy/move transaction.  Cancel will cancel the current file transfer or any
file transfers in the batch.

Working with Files in NFM
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COPYING AND MOVING FILES USING DRAG AND DROP

This is the easiest way to transfer files in NFM.  “Dragging” is done by
clicking on the file name (or group of file names) you want to transfer and
holding down the mouse button while you move the mouse, thereby
dragging the file with you.  You can drag/copy (drag a copy of the selected
file(s)) by simply dragging the file(s).  You can drag/move by holding down
[Shift] as you drag the file(s); note that this will not work when dragging
files from the Windows File Manager.  Note that when you move a file, the
original file will be removed.

You then “drop” the file(s) by releasing the mouse button at the place that
you want to copy or move the file(s).  The file(s) will then be copied or
moved.

Figure 4-4

DRAG AND DROP FROM YOUR PC TO AN NFM HOST:
You can copy files from your PC to an NFM host using the Windows File
Manager.  Select the file(s) you want to copy in the Windows File Man-
ager, drag them to an NFM directory window, and drop them onto the
area where you want to move them.  (You can only copy files to an NFM
host if you have permission to do so on that host).  Moving files from the
Windows File Manager to NFM using drag and drop is not supported
(due to Windows File Manager operation).

DRAG AND DROP FROM AN NFM HOST TO YOUR PC OR OTHER NFM HOST:
You can copy or move files from a NFM host to your PC or another NFM
host by selecting the file(s) on your NFM Directory window, dragging the
file(s) you selected ([Ctrl] drag to move) to your Windows File Manager
screen, and dropping them onto the area where you want to move them.
(You can only move files from an NFM host if you have permission to do
so on that host).

Working with Files in NFM
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COPYING AND MOVING FILES USING THE FILE MENU

You can also copy or move files from an NFM host to your PC or another
NFM host, (or from your PC to an NFM host) by typing the file origin
and destination using the NFM File menu, as described below.  This is
done the same way no matter where the source and destination files are
located.

1) Select the files or directories you want to copy or move using the mouse
(this is optional; if you don’t select any files, you can specify the file by
pathname as described below).

2) Choose Copy or Move in the File menu (or press F8 for Copy or F7 for
Move).  A <Copy> or <Move> dialog will appear, asking you to specify
the file origin and destination.

Figure 4-5

If you highlighted any files or directories before beginning the file
transfer operation, NFM will assume that you want to work with those
files, and will fill in the dialog box with those file names.

If you provide no pathname in this dialog, NFM will assume the files
you are specifying are found in the current directory on the current host
(the host directory window that is currently highlighted).  This means
that there is an advantage to selecting your origin directory before
beginning a file operation, to eliminate having to type a long pathname.

3) Specify the names of the origin and destination file(s) in the appropriate
format.  For a file on a NFM host, this would be in the following
format:

host:/files/myfile.txt

where host is the name of the host you are connected to;

and /files/myfile.txt is the path and filename of the file in that host’s
format.

Working with Files in NFM
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For a file on your PC, you would use the typical DOS format:

c:\files\myfile.txt

You can use these in any order; from NFM host to NFM host, from
NFM host to PC, or from PC to NFM host. (Even from PC to PC, if
you really must!).

The <Copy> and <Move> dialogs support the use of file wildcards, (?
and *), which allow you to substitute for characters that you do not
know (or wish to type).  For instance, you could copy files from
sunhost:/home/files/data??? or from c:\files\*.txt.

4) Click OK.  The specified file(s) will be copied or moved.

Remember that you will not be able to copy or move files to an NFM
host, or move files from an NFM host, unless you have permission on that
host.

COPYING AND MOVING FILES ON A SINGLE HOST
You can copy and move files on one NFM host using the techniques
described in the last section; however, you do not have to specify the
hostname as you did there, since the origin and target destination are on
the same system.

RENAMING A FILE/DIRECTORY

You can rename a file or directory by highlighting the file or directory you
want to rename, and clicking Rename in the File menu.  You will be
prompted for a new filename or directory name.  Type the name, and click
OK.

You can also specify the original and new names for the file/directory in the
dialog without highlighting them first.

CREATING A DIRECTORY

You can create a directory on a NFM host by selecting the location where
you want the directory, and choosing Create Directory from the File menu
(or pressing the Create button on the Toolbar).  You can then specify the
new directory name, and click OK to create the directory.

DELETING FILES/DIRECTORIES

To delete files/directories, select them using the mouse and choose Delete
from the File menu or press the Delete key on your keyboard.  (You can
also specify the file/directory name(s) in this dialog).  Click OK to delete
the files/directories.

Working with Files in NFM
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CONFIRMING FILE OPERATIONS

When you copy or move files, or delete or replace files on the host, you will
automatically be prompted to confirm that you want to perform those
actions.  You can enable or disable this confirmation step using the <Con-
firmation> dialog in the Options menu, shown below.

Figure 4-6

In this dialog, you can also specify whether to confirm mouse actions (any
drag and drop activity), whether to confirm automatic reconnection to a
host, and whether to ask for confirmation when translating a long filename
during file transfer.

Working with Files in NFM
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VIEWING AND PRINTING REMOTE HOST FILES
Once you have connected to a host, you may be able to directly view or
print files with Network File Manager.  NFM recognizes files just like the
Windows File Manager, by examining the file’s extension and checking to
see what application is associated with that type of file.  For instance, the
file “hello.txt” has extension txt, which is associated by Network File
Manager with the Windows Notepad application.  So, when you try to
view or print this file in Network File Manager using the Open or Print
commands, the file will automatically be opened/printed using Windows
Notepad.

Only files with file extensions can be opened by Network File Manager.

USING FILE ASSOCIATIONS

File associations in NFM work just the way they do in the Windows File
Manager.  You use an Associate command to tell NFM how to recognize
associations, so that you can open or print a file directly from NFM.

NFM automatically uses any associations that were set up in Windows File
Manager; you can then examine and change those associations and add
additional associations.

You can add a new association at any time.  You may find it convenient to
add associations when you are actually highlighting a filename that you
want to associate.

Click Associate from the File menu.   An <Associate> dialog will appear,
showing a list of file associations.  If you currently have a file highlighted,
any association for that file will display.

Figure 4-7

You can create a new association, or change an existing association by
typing the extension you want to associate into the Files with Extension
field (if you highlighted a file, it will already be there).

Working with Files in NFM
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You can then choose the application to associate this extension with from
the Associate With drop-down list.  If the application is not in the list, you
can use the Browse button to locate the application on your PC.

Because you are transferring the files (into your system memory) before
you open or print them, you may need to specify the file transfer type for
each file association.  For text files, make sure that the Open File As value is
set to ASCII to ensure that they will open correctly; for any other files
(including word processing documents), you will probably want to set this
value to Binary.  For more information, see the previous section on
“Setting the File Transfer Method.”

Click OK when you have finished making associations.

VIEWING A REMOTE FILE

You can open a file on a remote host by double-clicking on it, selecting the
file and pressing Enter, or choosing Open from the File menu. If there is
an association set up for that file,   NFM will launch the program associ-
ated with that file and display the file. (If there is no association for that
file, NFM will display a message informing you that there is no association
for that file).

If the file does not have an extension that you can associate with an
application, you will have to transfer the file to your PC before you can
open it in an application.

You can check the Minimize on File Open command if you wish to
automatically minimize the Network File Manager Console when any
NFM files are opened.

Viewing and Printing Remote Host Files
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VIEWING FILE PROPERTIES

NFM allows you to view information on files on the host using the
Properties and Quick Properties commands.  The information that will be
displayed is virtually the same information you will see if you are connect-
ing to the host with the correct host driver and are displaying all the file
details; therefore this feature is only really helpful if you are currently using
the Generic host driver, or if you need additional information about a file
that is not displayed, for some reason.

1) Select the file for which you want to see details.

2) Choose Properties from the File menu to display all available informa-
tion from the host in a dialog.  You can scroll through the dialog to read
all the information.  Click OK to close the <Properties> dialog.

or

Choose Quick Properties from the File menu (or press Ctrl-Alt-Enter)
to display the properties in the Status Bar.  The information will stay in
the Status Bar until you highlight another file.

Properties and Quick Properties work only for files; if you try to use
Properties or Quick Properties when highlighting a directory name, you
will be informed that the highlighted item is a directory.

PRINTING A FILE

If you have an association set up for the file you want to print, you can
print it by choosing Print from the File menu.  NFM will launch the
program associated with that file and print the file.

If the file does not have an extension that you can associate with an
application, you will have to transfer the file to your PC before you can
print it from an application.

Viewing and Printing Remote Host Files
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CONFIGURING CONNECTION OPTIONS
NFM has several options that allow you to control how you connect to
NFM sessions.

• You can specify advanced connection options for your session.

• You can specify default connection information that will fill out in
the “Connect To” dialog that appears at the beginning of every
session.

• You can change information for any Connections you have defined
in the NFM Connection List.

• You can have NFM automatically reconnect to any hosts you were
connected to in your last NFM session.

These options are described in the sections that follow.

ADVANCED CONNECTION OPTIONS

Advanced connection options, accessed by clicking the Advanced button in
the <Connect To> dialog, are available when you connect.  The options on
the right hand side of this dialog (General options and Transaction Log-
ging) can also be changed during  your session by choosing the Connec-
tion Settings command from the Options menu.

Figure 4-8

The <Advanced Connect Options> dialog options are described below.
Note that changing these connection options upon login will only affect
the session you are currently connecting to; if you want to save these
options, you can save them to a connection.  Alternately, you can use the
Default Connect Information command to set these options for all of
your sessions.  See “Setting Default Options” for more information on
setting this default information.

Viewing and Printing Remote Host Files
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Advanced Login Options
Port
You can specify the FTP port you want to connect to.  In most cases, the
default port, 21, will work.  Change this value only if you know that you
need to connect to a different port on the FTP host.

Show Login Greeting
NFM normally displays greeting information from the host you are
connecting to.  Greeting information usually identifies the host and
sometimes provides additional information about the host such as acces-
sible hours, user limits, etc.  The greeting information is displayed in a
separate dialog; you can scroll through the greeting using the scroll bars,
when displayed.  You can turn off the display of the greeting by
unchecking this option.

Initialize Commands
NFM allows you to pass a number of FTP protocol commands directly to
the FTP server immediately after login.  This option is provided to allow
you to pass commands to servers that require special setup.  This is an
advanced option; you should only use this if you are familiar with ftp
protocol commands or are specifically instructed that you need to send
special initialization commands when connecting to an FTP host.  You can
use any FTP protocol commands in this field except for data transfer
commands (RETR, STOR, LIST, NLST).  Internet RFC (Request For
Comments) 959 (5.3.1-5.3.2) describes FTP protocol commands and
command syntax.

For example: some AS/400 ftp servers time out very quickly, and allow you
to set a different time-out value using a TIME command.  If this was the
case for a server you were connecting to, you might type “TIME 60000”
in this field to set the timeout value higher.

You can provide several commands in this field, separated by commas
(spaces after the commas are optional).

Initial Directory
You can specify the initial directory you want to connect to once you
connect to the FTP server.  You can use this option to quickly connect to a
directory on the FTP server.  NFM also allows you the option of automati-
cally reconnecting to the last directory you were in, using the Reconnect
option; see “Automatically Restoring Connections” later in this section for
more information.

Configuring Connection Options
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Use Firewall
Some networks are protected by Internet firewalls.  Firewalls secure net-
works against outside access by requiring all information to and from
outside networks to go through the firewall.  If your network uses a
firewall, you must set up NFM so that it uses that firewall before you will
be able to successfully use NFM.  Currently, only ANS firewalls are
supported by NFM.

You set up NFM to use the firewall by setting up the firewall address and
your user ID and password on that firewall.  Your network administrator
should be able to supply this information.  The fields you should fill out
are described below.

Type
The type of firewall you are connecting to.  Currently, only ANS firewalls
are supported, so you should not change this option.

Address
The IP address of the machine which has the firewall on it (specifically, the
FTP Proxy portion of the firewall; some firewalls span multiple machines).
This will typically be a numeric IP address like 165.121.6.8.

User ID
Your user ID on the firewall.  This will be a unique ID on that firewall,
assigned by your network administrator, that you are required to use to
connect to the firewall.

Password
Your password on the firewall.  This is the password associated with your
User ID, also assigned by your network administrator.

Port
The port to connect to on the firewall.  For FTP, this is usually 21.
Change this option only if specifically instructed to by your network
administrator.

General Options
These options, as well as the Transaction Logging options, can be changed
during your NFM session as well as when you connect to an FTP host.

Configuring Connection Options
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Timeout if no response after __ seconds
This option controls how long NFM waits for response from the FTP
server before assuming that the connection has been lost.  This option
affects the initial connection to the host, reading in a new directory, or
trying to transfer a file.  If the FTP server does not respond within the
timeout value you specify, NFM will stop trying and will display a discon-
nect message.  The default of 30 seconds should work for most cases; if the
FTP server you’re connecting to takes a long time to respond, you may
want to increase this value so that NFM waits longer for a response before
timing out.

This value must be at least 20 seconds, and can be as high as 999 seconds.

Poke host every __ minutes to avoid inactivity disconnect
FTP hosts will disconnect from NFM after a certain period of time if you
are not performing any activity on that host (listing directories, transferring
files, etc).  Fortunately, NFM does not close when disconnected, and if you
try to continue to work on that FTP server you will simply be informed
that you were disconnected and asked if you want to reconnect.

You may, however, prefer not ever to be disconnected when working; you
can set this value in NFM order to “trick” the remote server into believing
that you are active on the host, even when you are not using NFM.

You can set this value between 1-99 minutes.  Setting the value to 1
minute will help keep you from being disconnected inadvertently; the
effect of  values will vary depending on the FTP server you care connected
to.

Passive Data Transfers
The FTP protocol which NFM uses to present remote file systems nor-
mally uses the PORT command to establish data transfer channels.  If you
need to get past Internet firewalls, or for some reason do not want to use
the PORT command for data channel establishment, you can check this
option to have NFM use the PASV command.

File Transfer Mode
When transferring files with NFM, you will need to choose between ASCII
(text) and Binary (non-text files, such as executable files or graphic and
sound files) methods of file transfer.  Basically, if a file contains special
“control codes,” (like a word processing document, graphics file, or a sound
file) it should be transferred as Binary.  You can specify the default file
transfer mode to use by choosing this option.  In most cases, you will

Configuring Connection Options
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probably want to leave this option as Binary, since you will probably
mostly be transferring binary files.

You can easily change this option during an NFM session by clicking on
the ASCII and Binary buttons on the NFM Toolbar.

If the wrong method is selected when you transfer a file, you may
have problems.  Transferred ASCII files may not display properly if
Binary mode is chosen, and transferred Binary files may not execute
properly if transferred using ASCII mode.

File List Format
You can use this option to specify how you want NFM to display details
about files.  By default, NFM displays files in Windows format;  in other
words, it displays them in the same order they are listed in the Windows
File Manager: name first, then size, date, time, etc.  When you are access-
ing remote file systems, you may want to display them in the order they are
displayed on that file system, i.e. the Native format.  For instance, UNIX
hosts display file details in this order:  flags, links, owner, group, size, date,
and name.

Select Windows to display files in standard Windows order, with name
first, then size, date, time, etc., or select Native to display files in the native
file format of the remote system.

Transaction Logging
You can have FTP log all of your session activity to a file or to the screen.
Logging your session activity may help you if you are having problems
connecting to a host, accessing directories, or transferring files, by showing
you the messages the host sends to NFM.

You can log three types of ftp transactions: FTP commands, FTP replies,
and FTP file lists.

FTP commands are commands sent to the host; when you ask to change
directories or copy files, etc.

FTP replies are the acknowledgement of those commands, such as "File
Copied Successfully".

FTP file lists are the file lists produced in response to an FTP LIST or
NLIST command.  These are the file lists you would typically see in a
character based FTP session.  For instance, every time you change a
directory, a new list of files is passed to NFM so that NFM can display the
new directory on your screen.

Configuring Connection Options
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Check which of these options you want to log.  By default, all three types
of transactions are logged.  If you check any of these options, your session
will automatically be logged to a window.  Each directory window in NFM
has a window pane, which is initially hidden, where the session will be
logged.

Figure 4-9

To display the logging pane, move your cursor to the thin border between
your NFM directory window and the NFM Status Bar (if you are not
displaying your Status Bar, it will be a border right on the bottom of your
screen).  Your cursor will turn into a double headed arrow which you can
push up to display the logging pane, (if you need more space to view
logging activity, maximize your NFM Console by clicking the Maximize
arrow in the upper right hand corner of the Console.)  Adjust the logging
pane until you can view the session activity.

The Clear Log command in the Window menu will clear all logging
window contents at any time.

If you want to save session activity permanently, or if you are having
trouble connecting to a host and want to view the log, you should log your
session to a file.  Check the Log to File box to have NFM log to a file.

Normally, the log file that is used is ftp.log in the \...\BIN directory of
your installation.  If you are using an NFM Connection to connect to the
FTP server, the log file will be renamed to a unique name for you.
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You can, however, specify any name (and location) you’d like for this file.
You can specify a new name for this file by typing it in the provided field;
it will be created.  Also, you can click the Browse button and specify a
directory and filename to use for the log file (again, if you specify a new
filename in the Browse dialog, it will be created).

All your session activity will be written to the file that you specified.  This
file is overwritten each time you start a new session.  If you want to save
your last session log, change the name of the log file you are using, and exit
and restart NFM.

You can read a log file using a text editor like Windows Notepad.

Configuring Connection Options
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SPECIFYING DEFAULT CONNECTION INFORMATION

You can have NFM automatically fill out all of the options you specify
upon connecting to a host, so that these options are always assumed.  For
instance, if you often login to anonymous ftp sites, you may want to have
NFM always specify user name of anonymous with a password of your user
name.  If you specify this information in the <Default Connect Informa-
tion> dialog, it will always display when you connect to a host (although
you can change it, if you need to).

The <Default Connect Information> dialog is produced by selecting
Default Connect Information from the Options menu.  This dialog is
filled out exactly as you would fill out the <Connect To> dialog.

Figure 4-10

Fill out any information you want to have display in the <Connect To>
dialog.

You can also click the Advanced button to specify default advanced options
for NFM.  For instance, if you need to use a firewall in order to use NFM,
you would want the firewall information to be filled out automatically.   A
<Default Advanced Connect Options> dialog will appear.

Figure 4-11

Fill out any information you want to have automatically appear in the
Advanced portion of the <Connect To> dialog.

Configuring Connection Options
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The information you provide in these dialogs is also used by default when
you add a new host using the Edit Connection List feature.  See “Viewing
and Changing your Connection List” for more information.

Configuring Connection Options
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VIEWING AND CHANGING YOUR CONNECTION LIST
NFM allows you to view all the Connections you created, create new
Connections, and edit information about those connections, using the
<Edit Connection List> dialog.  For more information on connections, see
the “Starting NFM” section of this chapter.

The <Edit Connection List> dialog, produced by choosing Edit Connec-
tion List from the File menu, will display all your Connections.

Figure 4-12

ADDING A NEW CONNECTION:
To add a new Connection, click the New button.  A dialog will appear,
asking you to specify information about the new connection.  You can
specify this information just as you would if you were connecting to the
host; see “Starting NFM” for more information on how to fill out this
dialog.  Click Advanced to specify advanced connection options.

Click OK when you are finished creating this connection; the next time
you connect, these settings will be used.

Figure 4-13

Configuring Connection Options
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EDITING A CONNECTION:
Highlight one of your connections and click Edit to edit the information
about the Connection.  A dialog will appear, allowing you to change any of
the specified information.  You can change the information in this dialog
(click Advanced to change advanced connection options).  Click OK when
you are finished editing the Connection; the next time you connect using
this connection these settings will be used.

Figure 4-14

DELETING A CONNECTION:
To delete a Connection, highlight the Connection name and click the
Delete button.  The Connection will be removed from the Connection list
and will not appear the next time you start NFM.

Configuring Connection Options
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AUTOMATICALLY RESTORING CONNECTIONS

You can set up NFM to automatically try to restore any connections that
were open the last time you used NFM.  Choose Startup in the Options
menu; the <Startup Options> dialog will appear.  Selecting the Restore
Connections at Startup option will cause NFM  to try to open all of your
currently open network connections.

By default, you will be prompted with a <Reconnect To> dialog for each
connection that NFM tries to reopen.  To reconnect to that session, click
OK.  You can, if you choose, ignore the reconnection and choose another
FTP Server to connect to, or choose Cancel to decline the reconnection.  If
you Cancel, you will be presented with the standard <Connect To> dialog.

However, you can choose to disable this login prompt, so that NFM
transparently reconnects to all of the current network connections the next
time you start NFM, without requiring you to login to each session.  You
do this by unchecking the Confirm Reconnections option.  If this option is
unchecked, the connections will be restored automatically.  (This option
can also be set using the <Confirmation> dialog).  You can also check
Restore Current Directory to automatically display the directory you have
current when the session is restored (as opposed to the home directory on
that host).

Configuring Connection Options
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DISPLAYING FILES IN NFM
When you display files and directories on a remote host, they appear in a
directory window.  Files will be displayed as documents, and directories will
be displayed as folders, similar to the Microsoft Windows File Manager.

There are several ways to change how files are displayed in the Network
File Manager. You can specify the following options:

• Which file details are listed.

• The order in which files are listed.

• Which files are listed.

These options will be set for the current session only.

The methods used to change these settings are described below:

SETTING WHICH FILE DETAILS ARE LISTED:
You can change which of the file details (such as Name, Date, Size, Owner,
etc) are listed by choosing All File Details, or Partial Details options in the
NFM View menu, as described below.

All File Details Displays all available file details for files
on the host you are connected to.  These
details will vary according to the host.

Partial File Details Allows you to specify which file details
you want to display.  Check the details
that you want to display, and click OK.
(You can also select this item by clicking
on the Details button on the Toolbar.)

You can change the size of the Name field by moving your cursor to the
separator to the right of the Name field until it turns into a double headed
arrow, holding down your mouse button, and moving it left or right to
change the size of the field.  Note:  this will not apply if you are in host
directory list format, or if you are using the Generic host driver to
connect to hosts.



4-33
NFM

SETTING THE ORDER IN WHICH FILES ARE LISTED:
NFM allows you to change how NFM sorts the files in the listing by
clicking on the detail header for that detail (as shown below).

Figure 4-15

You can also sort by choosing the Sort by... options in the Options menu.

The sorting is done by the methods described below.

Sort by Name
List files in alphabetical order (this is the default).

Sort by Type
List files in alphabetical order by their extensions (i.e. link.dll, test.dll,
auto.exe, timer.exe, story.txt).

Sort by Size, Date, Owner, Group, Etc.
Other sorting options will appear in this menu based on the available file
details of the host that you are connecting to.  Sort by size will list files
from smallest to largest, sort by date from oldest to newest.

SETTING WHICH FILES ARE LISTED:
You can also select which files are listed using By File Type in the View
menu.

By File Type...
This dialog allows you to specify whether directories, programs, docu-
ments, or other files (non-directories, programs, and documents) are listed.

You can also list files with any given file specification by typing the specifi-
cation using a wildcard combination (*, ?) in the provided dialog box.  To
select all files, leave this box blank.

If you use wildcards, you must use the wildcard conventions used on the
file system you are viewing.  For instance, on a UNIX system, specifying
*.txt would list only files with the extension txt, and specifying doc* would
list only files that begin with the first three letters doc are listed.

Displaying Files in NFM
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SAVING YOUR NFM SETTINGS
NFM will save your current workspace and settings when you exit if you
have checked Save Workspace on Exit in the Options menu.   Whenever
NFM starts, it restores the workspace to the last workspace that was saved.
This includes reestablishing all connections, if you have the Restore
Connections on Startup option (set using the Startup option in the
Options menu).

The types of settings that will be saved are:

• Startup settings (whether to open File Manager on Startup, whether
to automatically reconnect to the host)

• Console Settings (whether to display the Toolbar and Status Bar, the
Toolbar type, the position and size of the NFM and File Manager
windows).

• All your connection settings, including the layout (size and position)
of NFM’s work area, and all connection related settings such as the
file listing options in the View menu.

Changes to the Associations and the Connection list are saved automati-
cally, regardless of the Save Workspace setting.

Saving Your NFM Settings
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SPRY Gopher

SPRY Gopher™ is a networked information search and retrieval application
for the Internet.  With SPRY Gopher, you can access many different types
of information regardless of the information’s location, using whatever
tools (ftp, telnet, a GIF viewer, etc.) are appropriate to the task.

Gopher displays and retrieves information from Internet Gopher Servers,
sites on the Internet that are set up with Internet information, organized
by topic.  Gopher Servers are usually set up as menus; Gopher is set up
with an easy-to-use tree-based screen that makes it even easier to navigate
up and down these lists of information.

FEATURES
• Access a variety of resources including telnet sites, search databases,

and files: from Macintosh and DOS binary files to sound and
graphic files.

• Automatically transfer files to your PC, or immediately retrieve
information (like text files, graphic files, and sound files) into the
application you specify.

• Create custom Gopher windows containing the resources you want
to access.

• Connect to multiple Gopher Servers at the same time; open multiple
Gopher windows.

• View gopher information with intuitive Windows tree structure,
making it easier to navigate “gopherspace”.  Gopher tracks every
path you take to get information.

• View Gopher resource information in Status Bar.

• Designate primary and secondary Gopher Servers to connect to.

• Stop lengthy Gopher processes.

• Change the length of time Gopher tries to open a menu or resource.

• Connect to any Gopher server at any time.
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WHAT IS GOPHER?
Gopher was designed as a unique interface for navigating, viewing and
retrieving resources on Internet Gopher Servers.

Because the Internet contains such large quantities of information...

• in widely divergent locations
universities, businesses, and private enterprises worldwide

• in a variety of different formats
text and binary files,  graphic images, sounds, databases

• requiring a variety of tools
ftp, tn3270, telnet, search applications

...it became important for people to find a way of retrieving this informa-
tion without having to become information retrieval specialists.  Gopher
Servers were developed to help meet this need.

Gopher Servers index a wide variety of information in a relatively orga-
nized fashion.  Information is grouped on a Gopher Server by category, not
by location, and the organization of the information is done by the Gopher
Server administrator.  Much of the information you find on a Gopher
Server may actually be located elsewhere on the Internet; that is why we
refer to Gopher as a tool for “navigating” the Internet.

A Gopher Server might list a category of items, like Electronic music, and
include text files, sound files, music programs for IBM and Macintosh, and
a search database for song titles.  These items might be located at different
sites around the world.  But when you use gopher, you don’t need to know
where these resources are actually located to use them (although this
information is available to you).

Gopher clients are programs that can connect to Gopher Servers and
display and retrieve the information they hold, using whatever tools are
appropriate.  Gopher is a Gopher client that is an invaluable resource for
opening, viewing, and retrieving information, because it provides a flexible
interface that you can adapt to your own information needs.  You can
traverse Gopher Servers using a familiar Windows File Manager style tree
structure, and click on the resources you see with your mouse.  You can
search for gopher information, connect to other hosts (using a telnet
application, if you have one available), and transfer files to your PC or
directly view them with your existing Windows applications.  Gopher also
includes many advanced customization features.

What is Gopher?
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STARTING GOPHER
You can start Gopher by clicking on the SPRY Gopher icon.  Gopher will
start connecting to a Gopher Server address, that was pre-defined during
installation.  You can set Gopher to connect to a different Gopher Server
on startup, if you prefer, or start Gopher without attaching to a Gopher
Server (see the next section for more information).

When Gopher connects to the Gopher Server, you will see the Gopher
Console, an area which displays the Gopher Server information.

Figure 5-1

There are two windows on the Console, the browser pane, on the left, and
the list pane, on the right.  These panes will initially list the same informa-
tion, but as you browse with Gopher, you will primarily use the browser
pane to browse Gopher menus, whereas the list pane will list the informa-
tion you find.

The Toolbar at the top of the console contains Toolbar buttons that serve
as shortcuts for Gopher menu items.  The Status Bar at the bottom of the
Console displays concise help for Gopher menu items and Toolbar buttons
and will display status messages such as the location of Gopher resources.
The Toolbar style can be changed by choosing Toolbar Style in the Op-
tions menu.  Both the Toolbar and the Status Bar can be shown or hidden
by checking or unchecking Show Status Bar and Show Toolbar in the
Options menu.

EXITING GOPHER
You can exit Gopher by choosing Exit from the File menu.  You can also
doubleclick on the Windows System Menu to exit Gopher.

Starting Gopher
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CONNECTING TO GOPHER SERVERS

There are several ways Gopher can connect to Gopher Servers.

CONNECT TO THE DEFAULT GOPHER SERVER ON STARTUP

Gopher is initially set to automatically connect you to the SPRY Gopher
Server, because the SPRY Gopher Server is set up as the Default Gopher
Server in Gopher.  You can change the server that Gopher starts with, or
set Gopher to start with no Gopher Server, by using Startup Settings in
the Options menu.  See the next section, “Gopher Startup Options,” for
more information.

CONNECT TO THE DEFAULT GOPHER SERVER AFTER STARTUP

You can connect to the Default Gopher Server (described above) at any
time by choosing Connect to Default Server in the Connections menu or
pressing Ctrl-D.  This might be useful if you closed the connection to your
Default Server, and want to reconnect.

CONNECT TO A NEW GOPHER SERVER AT ANY TIME.
To connect to a new Gopher Server at any time, choose Connect to New
Server from the Connections menu, or click the New button on the
Toolbar.  You will be asked to specify the Title, Host, Port, and Selector for
that Server.

You can use this command if you want to open a second (or third, or
fourth...) Gopher Server after you’ve connected.  You may also use this
command if you started Gopher without automatically connecting to a
Gopher Server.

OPEN A SAVED GOPHER FILE

Gopher allows you to create customized Gopher windows containing
Gopher resources you want to frequently access; you can save these win-
dows to files and open them at any time.  You can also use this method to
store the locations of several different Gopher Servers. You use the Create
New Window command in the Window men to create windows, and the
Save or Save As command in the File menu to save the windows to Gopher
Files.  See “Customizing Gopher” for further information.

Depending on where the Gopher Server is you are connecting to, and how
busy the time of day, there may be an initial delay connecting to the
Server.  Please be patient while connecting.  A timeout message should
appear if no connection can be made.

Starting Gopher
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GOPHER STARTUP OPTIONS

You can, if you wish, setup other Gopher Servers to connect to automati-
cally (or start Gopher without connecting to any Gopher Servers).  The
Gopher Startup options are described below.

STARTING GOPHER WITH OTHER GOPHER SERVERS:
Gopher includes a predefined Gopher Server, which will allow you to
navigate the Internet, and reach almost all other Gopher Servers.  You can
start up Gopher with other Gopher Servers, if you wish.  Note that for the
most part, they all draw from the same pool of information; most Gopher
Servers have doorways to other Gopher Servers all over the world.

Choose Startup Settings from the Gopher Options menu.  You will see the
<Startup Settings> dialog.

Figure 5-2

You can define two Gopher Servers in this dialog.  The server defined as
Default Server will be started automatically when Gopher starts, if Con-
nect to Default Server on Startup is checked.  (If this option is not
checked, Gopher will start without making any connections.)  The server
defined as Backup Server is optional.  When you define a backup server,
Gopher will automatically try to connect to that server when the Default
Server is not available.  (You will see an error message if Gopher cannot
connect to the Default Server, and then Gopher will try connecting to the
Backup Server.)

This option is designed mainly to designate a main Gopher Server to start
Gopher.  If you want to be able to quickly access a Gopher Server or a
saved Gopher configuration, you can create a Gopher Files storing the
address of that Gopher Server, as described in the “Customizing Gopher”
section later in this chapter.

Starting Gopher
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The fields for the <Startup Settings> dialog are described below in detail.

DEFAULT/BACKUP SERVER FIELDS

Title (Required)
A name you choose for the Gopher Server.  This can be any name you
choose.

Host (Required)
The fully qualified domain name (such as gopher.interserv.net) for the
Gopher Server.

Gopher will specify a default Port, Selector, and Type for the Gopher
Server, as described below.  Do not change these unless you specifi-
cally know that they should have different values.

Port (Optional)
The port for the Gopher Server; usually 70.  Do not change this option
unless you know it to be different from 70.

Selector (Optional)
This is an advanced setting similar to a DOS Pathname which can be used
to indicate the location of a resource on the host.  In most cases, you will
not need to change this field.

Type (Optional)
The Type setting (also known as the URL, or Uniform Resource Locator),
is a setting used throughout Gopher (in Gopher, and other gopher pro-
grams) to define the type of a Gopher resource.  For a Gopher Server, this
value should be 1 (Gopher Subdirectory).  See “Understanding Gopher
Resources” for a listing of Type settings.

After setting these options, click OK.  The options will be saved automati-
cally; the next time you start Gopher, it will try to connect to the Server
you defined.

Starting Gopher
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NAVIGATING THROUGH GOPHER
When you first start Gopher, the Gopher Console displays the main
Gopher Server directory and subdirectories, in a window.  Unlike other
Gopher applications, Gopher uses a tree structure to display Gopher
information; other gopher applications show this information in “menu”
format.

Figure 5-3

There are two parts to a Gopher window:  the browser pane (on the left),
and the list pane (on the right).  You will see the name of the main Gopher
directory in the browser pane, and a list of that directory’s subdirectories
and resources in the list pane.  You can immediately click on the directory
folders to open them and find the information they contain.

Gopher will supply you with a great many resources.  Resources in Gopher
can be text files, applications, sound and graphic files, telnet sites, search
databases, and more.  You might find information such as sports scores,
reference books, magazine articles, pictures of helicopters, and fragments of
movie dialogue.  You can access many of these resources just by double-
clicking on them.

The next section describes Gopher resources and how to set up Gopher to properly
access them.

Navigating Through Gopher



5-8

UNDERSTANDING GOPHER RESOURCES
It is helpful to know something about the different kinds of resources that
are found on Gopher and how they work.  The icons next to resource
names in the Gopher Console will show you what the resources represent.
Most of the resources will be items you can view, retrieve, or use.  Gopher
will allow you to access most of the resources you see just by double-
clicking on them.

Gopher automatically knows how to access many of these resources, but
you may have to set up additional associations in Gopher before Gopher
will be able to access them.

The table below shows the icons you will see in Gopher and the resources
they represent (along with the Resource Type, a field used by Gopher to
identify the resource), and describes the actions that occur when you access
them.

The Resource Type is also known as the URL, or uniform resource locator.
Gopher reads this information from the Gopher Server to recognize the
resource.

RESOURCES IN GOPHER

ICONICONICONICONICON RESOURCE(TYPE)RESOURCE(TYPE)RESOURCE(TYPE)RESOURCE(TYPE)RESOURCE(TYPE) ACTIONACTIONACTIONACTIONACTION

Text File (0) The file will be opened by the text editor or
word processor you have specified using the
Associate command.  You can then use your
editor to save, print, or change the file.

Subdirectory (1) Displays other subdirectories and/or lists of
resources.

Macintosh file (4) Gopher will transfer the file to your PC; you
will be prompted for a filename to save the
file under.

DOS file (5) Gopher will transfer the file to your PC; you
will be prompted for a filename to save the
file under.

UUencoded file (6) Gopher will transfer the file to your PC; you
will be prompted for a filename to save the
file under.

Understanding Gopher Resources
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UUencoded files are binary files encapsulated
in an ASCII header and footer; they must be
decoded using a uuencode/uudecode
program.

Search (7) This indicates that you can search for the
type of information specified in the name of
this resource.  Clicking on this item will
bring up a search box.

Figure 5-4

There are different ways to search for
information that are dependent on the
resource.  A common search method is simply
to type keywords in the box that appears.  For
instance, on a search item called Song Lyric
Search you might type the keywords night
and moon.  This would bring up all of the
articles indexed in that search database that
contain those words.  Depending on the
gopher resource, you might get all the lyrics
containing night and moon, or all the lyrics
containing night or moon.

Telnet (8) Clicking on this icon will start a Telnet
session to connect you to the host which has
the resource specified.  This is currently set
up to use the SPRY Telnet program.  If you
wish to use a different program to connect to
Telnet resources, you can use the Associate
command, described in the next section.

Gopher may provide a login ID and password
for the Telnet resource you are accessing; type
that ID, and any password (often you are
asked to specify your e-mail address as a
password).

Understanding Gopher Resources
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Binary (9) (Nonspecific binary file).  Gopher will
transfer this file to your PC; you will be
prompted for a filename to save the file
under.

Image (I) If you specified a graphics application using
the Associate command, the image file will be
opened by that application.  If you do not
have a graphics application, the image will be
stored in a temporary file.

GIF (g) If you specified a GIF viewer application
using the Associate command, the GIF file
will be opened by that application.  If you do
not have a GIF application, the image will be
stored in a temporary file.

tn3270 (T) Clicking on this icon will start a tn3270
session to connect you to the host which has
the resource specified, using the tn3270
program you specified with the Associate
command.  If you do not have a tn3270
program, you will not be able to access these
resources.

Sound (s) If you specified a sound player application
(like Microsoft Windows built-in Media
Player or Sound Recorder) using the
Associate command, the sound file will be
opened by that application.  If you do not
have a sound application, the image will be
stored in a temporary file.

Server Error (3) This icon usually indicates that the data
object is not recognized by Gopher.  The
Server may be unavailable, or the resource
may be incorrectly identified by the server.

Understanding Gopher Resources
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ACCESSING RESOURCES: ASSOCIATIONS
Gopher lets you access many different kinds of resources.  Most of the
resources are files (text files, applications, graphics files), that you will want
to view or use; others, such as Telnet and tn3270, connect you to remote
systems.  Gopher’s behavior when accessing these resources is described
below.

BINARY FILES
Gopher will prompt you with a file dialog allowing you to save the binary
file as a file on your PC.

TEXT FILES, GIF FILES, IMAGE FILES, SOUND FILES
Gopher saves these files to temporary files, and will try to open them with
the application associated with them.

TELNET AND TN3270 NODES
Gopher will try to access these nodes using the application associated with
them.    For instance, when you click on a graphics file, the file will be
stored in a temporary file (perhaps called TEMP.IMG).  You will not notice
this process, it is automatic.  Then, if you have associated up a graphics
application to view the image with (such as Windows Paintbrush), that
application will be started, and will try to open the image.

Gopher allows you to access certain types of resources immediately, by
setting up application associations for those resource types.  This means that
when you double-click on a resource, Gopher will automatically try to
access that resource using the application you specify.  For instance, you
might want to access Telnet resources using your Telnet program, or access
text files using Microsoft Word for Windows; you could set up these
associations using the Associate command.

How Associations Really Work:  Gopher launches the application with the
name of the temporary file that it used for the resource as a parameter on
the application’s command line.  If you are using Windows Notepad as the
associated application for Text Files in Gopher, when you click on a Text
File resource called “Knock Knock Jokes”, Gopher would actually save the
Knock Knock Jokes file to temp.txt, and then execute “NOTEPAD
temp.txt.”

Accessing Resources: Associations
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SETTING UP ASSOCIATIONS:
Select Associate in the File menu, or click the Associate button on the
Toolbar. The <Associate> dialog will open.

Figure 5-5

The <Associate> dialog lets you view and change the associations for the
different types of resources in Gopher (see “Understanding Gopher Re-
sources” for more information about resources).  When you select a type of
file in the Files of Type: dialog, you will see the current association appear
in the Associate with: field.

You can change an association by changing the Associate with value to the
application you desire.  Type the path and filename for the application in
the Associate with: field, or browse files and directories on your PC by
clicking the Browse button—a Windows file search dialog will appear;
when you have found the directory and file you want to use, click OK.

Figure 5-6

When you have specified all the changes you want to make to the associa-
tions dialog, click OK.

If you correctly associated the resource, when you next doubleclick on that
type of resource, the associated application will be started and will try to
open that resource.

When you open a resource using an associated application, you are actually
active in the other application, and can use that application as you would
normally.  Closing that application will not close Gopher.

Accessing Resources: Associations
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CUSTOMIZING GOPHER
There are several ways you can customize Gopher.  Gopher allows you to
create new Gopher Windows, containing just the resources you want to
view.

For example, you may find a category called “Professional Sports Sched-
ules” that you will want to check regularly.  However, to locate it, you
customarily have to navigate through several Gopher subdirectories to find
it.  Gopher lets you create a new window with “Professional Sports Sched-
ules” as its title.   You can save that window to a file, so that you can open
a connection to that resource immediately.

Figure 5-7

With Gopher, you can do several things.  You can:

• Create a new window, with the subdirectory you have highlighted as
the main directory of that window (as described above).

• Rename a Gopher window.

• Save a window to a Gopher File, so that you can quickly retrieve it
and open only the resources that you want.

• Open a saved Gopher File to quickly access resources.

• Cut and paste Gopher resources from one window to another.

• Add a new resource to any Gopher window.

These tasks are described in this section.

Customizing Gopher
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CREATING A GOPHER WINDOW

You can create a new window in Gopher using any subdirectory as the
main, or “root” topic.  For instance, perhaps you often access the item
“Professional Sports Schedules” from the Gopher tree shown below, and
want to create a separate window for it, rather than having to click on
“News, Entertainment, Weather, Sports” and “Professional Sports Sched-
ules” each time you want to access the sports schedules.

Figure 5-8

You would do this by selecting “Professional Sports Schedules” (or any
other subdirectory for which you want to create a separate window), and
using the Create New Window command in the Window menu.

Before you can use the Create New Window command, however, the
subdirectory you want to create the window from must be in the list pane
on the right hand side of the screen.  You can do this by clicking on the
“parent” topic of the target subdirectory, so that your topic moves to the
list pane.  In the example provided, you would have to click on News,
Entertainment, Weather, Sports to get the topic over to the list pane.  Then
you could select the “Professional Sports Schedule” subdirectory and choose
Create New Window from the Window menu, or click the Create button
on the Toolbar.  A new window would be created.

Customizing Gopher
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Figure 5-9

Depending on how Gopher is set up, this new window may appear to
“replace” your current screen; however, it didn’t.  Your other windows are
still open–just choose Tile or Cascade from the Window menu to show all
the windows at once.  Or switch between windows by selecting the window
titles from the titles shown in the Window menu.

You can, if you wish, rename a Gopher window by selecting the window
and choosing the Rename Window command from the Window menu.
Specify a new name for the window, and click OK.

SAVING A WINDOW TO A GOPHER FILE

Once you have created a new window, you should save it to a Gopher File,
so that you can open it at any time.  You do this by selecting the window
(if you have several open) and choosing Save (or Save As, if you have
already saved this window and want to save it under a different name) from
the File menu. You can also press Ctrl-S.  You will see a Windows file
search box asking you to specify the name of the Gopher file to save the
window to; an extension of .GGG is suggested.  Specify a name and click
OK.  The Gopher window will be saved to the filename you specified.

OPENING A GOPHER FILE

You can open a saved window at any time by choosing Open in the File
menu or clicking the Open button.  You can also press Ctrl-O.  You will
see a Windows file search box asking you to specify the name of the
Gopher File to open (it will look for files with extension .GGG by default).
Specify the filename and click OK.  When you open the Gopher File,
Gopher will connect to the main directory in that window and displays the
resources under that directory.  (Note: if the resources change, you will see
the new resources).  You can open as many saved windows as you like.

Customizing Gopher
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CUTTING, COPYING, AND PASTING WINDOW ITEMS

You can remove any resources from a Gopher window (cut), or copy
resources from them to paste in other windows, as described below.

REMOVING A RESOURCE FROM A GOPHER WINDOW:
After highlighting the resource you want to remove, choose the Cut
command from the Edit menu, or click Ctrl-X.  The resource will be
removed from the window, and the resource information will be copied to
the Windows Clipboard, so that you can paste them in other windows, if
desired.

COPYING RESOURCES FROM A GOPHER WINDOW:
After highlighting the resource you want to copy, choose the Copy com-
mand from the Edit menu, or click Ctrl-C.  The resource information will
be copied to the Windows Clipboard, so that you can paste them in other
windows, if desired.

PASTING A RESOURCE INTO A GOPHER WINDOW:
You must have either cut or copied a Gopher resource in order to paste it
into another window.  Highlight the place in the window where you want
to paste the copied or cut resource--the resource will be pasted just under-
neath the resource you highlighted--and choose Paste from the Edit menu,
or click Ctrl-V.  The new resource will be pasted at the bottom of the
window.

You can use these features to create a custom window with your favorite
resources and then save the Gopher session containing that menu and open
it whenever you want to access those resources.  Do not forget to save the
window, so your new menu or changes to resources will be preserved.

Customizing Gopher
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ADDING A NEW RESOURCE TO A WINDOW

You can add new gopher items to a window.  Highlight the window you
want to add the item to, and choose Add New Item from the Edit menu.
You should then specify information about the item you want to add.

Figure 5-10

Title (Required)
A name you choose for the resource.  This can be any name you choose.

Host (Required)
The address of the host where the resource is found (such as
gopher.tc.umn.edu).

Port (Optional) 
The port for the resource (usually 70).  Leave this option blank unless you
know the specific port for this resource.

Selector
You may need to fill out this item to properly connect to a resource.  This
is a setting similar to a DOS Pathname which can be used to indicate the
location of a resource on the host.  The syntax of the selector is N/
Selectorinfo, where N is the Type ID of the resource. (Ex:  1/Libraries/
Reference Books/PeriodicTable)

Type (Optional)
Type is a setting used throughout Gopher (in Gopher, and other gopher
programs) to define the type ID of a Gopher resource.  For a Gopher
Server, this value should be 1 (Gopher Subdirectory).  See the “Under-
standing Gopher Resources” table earlier in this chapter for a listing of
Type IDs.

Click OK to add the resource item; it will be added to the window just
below the currently highlighted resource.  You must save the window using
the Save command in order to keep the item in the window.

Customizing Gopher
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LOCATING A RESOURCE: PROPERTIES
Whenever you open a subdirectory, the Status Bar will display the location
of that subdirectory (in other words, the location of that Gopher Server).
This is a quick way for you to know where the resource you are looking for
is located.  However, sometimes you may want to know more information
about where a resource is located--perhaps to access it using another
application.

You can choose Properties in the Connections menu, or click the Proper-
ties button to examine information about a Gopher resource.

Figure 5-11

The fields in this screen are described below.

The Title is the name the Gopher Server assigned to the resource.

The Host is the location of this resource.  This hostname is useful informa-
tion as it indicates where you could reach this resource using other applica-
tions, if necessary.

The Port is the port of this resource; this may vary depending on the
Server the resource resides on.

The Selector is the exact location of the resource on the host.  Like the
host, this item may help you locate the resource if you connect to the host
using another application.

The Type is the Resource Type ID of this resource.  Refer to the “Under-
standing Gopher Resources” Table earlier in this chapter for the list of
resource type IDs and what they mean.

Locating a Resource: Properties
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SETTING GOPHER OPTIONS
Gopher allows you to  change how long  Gopher waits for a connection
and the number of times it tries to connect.  You can also control whether
the Toolbar and Status Bar options are displayed and what font is used in
Gopher windows.

CHANGING THE TIMEOUT LENGTH AND THE NUMBER OF CONNECTION TRIES:
Choosing Preferences in the Options menu will produce the following
dialog:

Figure 5-12

Timeout length defines how long Gopher will wait for the connection to
complete when you try to access a Gopher resource. The default is 30
seconds.

Maximum Number of Connection Tries defines how many times Gopher
will try to open a connection to a resource.  The default is 20 times.

In other words, with the settings shown above, Gopher would try to
connect 20 times, waiting 30 seconds each time.

You can also use this dialog to show the Gopher Toolbar and Status Bar.

SETTING THE GOPHER FONT:
You can choose Font from the Options menu to set the font, font style and
size that Gopher uses to display text in Gopher Windows.  Changing the
fonts in Gopher will change the text appearance in the current window
only, and the screen window will resize to maintain the current view.  (To
change the font in another window, you must choose Font again with that
window highlighted).

The <Font> dialog box displays a standard Windows font selection screen.
Choose the font, font style and font size you want for the current session
and click OK.  The font changes will take effect only in the current session
unless you have Save Settings on Exit checked.

Setting Gopher Options
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FINDING INFORMATION IN GOPHER
There is no formal method for finding information in Gopher; a utility
named Veronica does exist to allow you to search for information through-
out “gopherspace” (all the gopher servers everywhere).  You will find this
utility on many Gopher Servers (on the SPRY Gopher Server, it is found as
resource “Search Gopherspace with Veronica”).

Veronica is used just like other search utilities throughout Gopher; just
type the text that you hope to find in a resource title on Gopher.  Veronica
will locate it for you.



Chapter 6
SPRY Telnet

SPRY Telnet™ is a terminal emulation application which allows you to
connect to a remote host and execute programs as if you were directly
working on that host, using an easy-to-use, customizable Windows inter-
face.

SPRY Telnet’s features include printing and capturing of session activity,
login scripts, custom configurable sessions, and support for multiple
sessions.

SPRY TELNET FEATURES
• Supports VT52, VT100, and VT220 terminal emulation.

• Supports 80 or 132 column mode.

• Open up to 15 concurrent Telnet sessions.

• Save your Telnet settings to custom sessions that can be started
automatically when starting Windows or by clicking a custom Telnet
icon.

• Capture Telnet sessions to file or printer.

• Print session text, or copy session text within SPRY Telnet or to
other Windows applications.

• Paste information from other Windows applications to an applica-
tion in Telnet.

• Automate sessions with Telnet script language.

• Customize your terminal, fonts, and colors.

• Use the Remember hosts feature to remembers the hosts you’ve
connected to.

• Edit Telnet host names, addresses, and descriptions.

• Enable/disable the Telnet scrollback buffer, and set scrollback buffer
size.
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STARTING TELNET
You can start SPRY Telnet by clicking on the SPRY Telnet icon.  You will
see the <Open Telnet Session> dialog.

Figure 6-1

You are prompted to type in either a Host Name, Session Name, or IP
Address, or select a Host or Custom Session from the lists.  You can also
specify a telnet port, if necessary.  These selections are described below.

HOST NAME/HOSTS LIST
Type the name of the host in the provided box and click OK to open a
session to that host, or choose a host from the Hosts: list by double-
clicking its name.

Hosts in the Hosts List are hosts that you connected to with the Remember
new hosts option checked.  You can maintain this list of hosts inside Telnet
using the Edit Hosts command; see “Editing the Telnet Hosts List” for
more information.

SESSION NAME/CUSTOM SESSION LIST
SPRY Telnet allows you to create custom sessions, telnet sessions which you
create that save your current connection information (host name, port) and
any settings for that connection (login script, colors, size, terminal settings,
etc.).  This allows you to quickly connect to a host using the settings you
prefer.  For more information on custom sessions, see “Using Custom
Sessions” later in this chapter.

Any custom sessions you create will appear in the Custom Sessions: list.
You can start a custom session by double-clicking on the session name.

Starting Telnet
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IP ADDRESS
You can also connect to a host by specifying its IP address (such as
165.121.6.55) or its Fully Qualified Domain Name (such as
marshwiggle.narnia.com).  Type the IP Address or Fully Qualified Domain
Name in the supplied field, and click OK.

PORT
SPRY Telnet’s default, 23, will work for most hosts.  Only change this
number if you are connecting to a host whose port number is not 23.

REMEMBER NEW HOSTS
Checking this option will cause SPRY Telnet to remember all the new hosts
you type into the Host , Session Name or IP Address box, storing them in
the Telnet Hosts list.  This option is checked “on” by default.  Uncheck
this option if you don’t want SPRY Telnet to remember the host you are
connecting to and add it to your Hosts: list.  See “Editing the Telnet Host
Lists” later in this chapter for more information.

Once you have selected a host, session, or IP address, click OK.  SPRY
Telnet will attempt to open a Telnet session to the specified host. If a
connection is made, a Telnet Console with the name of that host, session,
or IP address will be opened, and the host’s ‘login’ prompt will be dis-
played.

Figure 6-2

SPRY Telnet will display “Connected” at the bottom of your screen if a
connection is made, and you will see the login prompt for your host.

Starting Telnet
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The Toolbar at the top of the Console contains buttons that serve as
shortcuts for Telnet menu items.  You can see the meaning of a Toolbar
button by putting your mouse on top of it; the Status Bar will display the
function of the button.   The Toolbar style can be changed between Picture
& Text, Picture only, and Text only by choosing Toolbar Style from the
Settings menu.

The Status Bar at the bottom of the screen displays concise help for SPRY
Telnet menu items and Toolbar buttons, and contains display lights that
show the status of Capture to File, Echo to Printer, and Num Lock.

Both the Toolbar and the Status Bar can be shown or hidden by checking
or unchecking Status Bar or Toolbar in the View menu.  The Toolbar and
Status Bar will be displayed if checked.

EXITING SPRY TELNET

Logging out of your remote host will automatically exit SPRY Telnet; this
is the recommended way to end a Telnet session.  You can also exit a SPRY
Telnet session by choosing Exit from the File menu or by double-clicking
the Windows System menu in the upper left hand corner of the Telnet
console.  This will only close the Telnet session that is currently active.  You
must individually close each session you have open; there is no way to close
all open Telnet Sessions.

OPENING OTHER TELNET SESSIONS

You can open a Telnet session as described earlier by clicking on the SPRY
Telnet icon.  You can also start a Telnet session from within your current
Telnet session by clicking the Open button on the Toolbar or choosing
Open Session from the File menu.  You will see the <Open Telnet Session>
dialog and can begin a new Telnet session.

You can easily switch between open Telnet sessions by using the Windows
Task Switcher (holding down Alt and clicking the TAB key until you see
the session you want, then letting go of both keys.)  Alternately, you can
minimize sessions at the bottom of your screen (using the Minimize arrow
in the upper right hand corner of your Telnet Console or the Minimize
option in the Telnet Windows System menu).

Starting Telnet
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EDITING THE TELNET HOSTS LIST
SPRY Telnet includes an Edit Hosts feature that allows you to edit the
name, address and port, and descriptions of each host that you have
“remembered” using the Remember New Hosts feature.  These hosts were
added to your Hosts List.  When you choose Edit Hosts from the File
menu, the dialog below appears.

Figure 6-3

ADDING OR EDITING A HOST:
To add a new host, click the New button, or click Edit to edit an existing
host.  A dialog like the one below appears; the dialog will be empty if you
are adding a host.

Figure 6-4

To add a host, fill in a name for the host, the host address (either an IP
address or a Fully Qualified Domain Name), and a description for the host
(optional), and click OK.  The host will be added to your hosts list.

To edit a host, change the appropriate fields, and click OK.  You will see
the changes you made the next time you start Telnet.

DELETING HOSTS:
To delete a host, select that host with your mouse by clicking on it to
highlight the host’s name, and click Delete.  The host will be removed
from the host list and will not appear the next time you start Telnet.

Editing the Telnet Hosts List
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PRINTING IN TELNET
You can print the text in your current Telnet screen to the printer you have
selected in Windows.  If you wish to print more than one screen of text, see
the next section, “Capturing Telnet Activity to a File or Printer.”

PRINTING IN TELNET:
Click the Print button on the Toolbar or choose Print from the Telnet File
menu.

SPRY Telnet will print the selected text to the default printer (selected in
Windows).  To print to a different printer, change Print Setup in the Telnet
File menu before printing.

Printing in Telnet
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COPYING AND PASTING TEXT IN TELNET
You can copy some or all of the text on your SPRY Telnet screen, and paste
it back into your Telnet screen or into another Windows application.  You
can also paste text from other Windows applications to your SPRY Telnet
screen.

You might want to use these features if you wanted to paste text you’ve
created in a Windows word processing program into an editor on your
remote host.  Or you might want to copy text displayed on your Telnet
screen (a list of files or usernames, for instance), and paste it into a com-
mand you are typing or a message you’re addressing, or paste it into
another Windows application.

COPYING TEXT FROM TELNET:

1) Select text using the mouse, or select all the available session text by
choosing Select All from the Telnet Edit menu.

2) Click the Copy button on the Toolbar, choose Copy from the Telnet
Edit menu, or click the right mouse button (with the text selected).

You will not notice any changes on your screen, but the selected text has
been copied to the Windows Clipboard, and is now available to be pasted
either in another Windows application (using that application’s Paste
command) or using the Paste command in SPRY Telnet (described below).

PASTING TEXT INTO TELNET:
You can use the Paste  command to paste information into your Telnet
screen at the current cursor position.  Paste will only be available if you
have recently used the Copy command in SPRY Telnet or in another
Windows application, or if there is information currently in the Windows
Clipboard from another source.

Note that Paste will only work  if you are in a position where you can
paste text; for instance, in a text editor with the cursor in insert mode.

1) Move your cursor  to the place on your Telnet Console where you want
to paste information (at your prompt, in your text editor, etc.):

2) Click the Paste button on the Toolbar, choose Paste from the Telnet
Edit menu, or click the right mouse button.

The information you want to copy will be pasted (inserted) at the current
cursor location.

Copying and Pasting Text in Telnet
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CAPTURING TELNET ACTIVITY TO A FILE OR PRINTER
You can capture text from your Telnet session to a file or printer; this
redirects all the output from your session to the file or printer from the
moment you start the capture command.  SPRY Telnet also allows you to
capture the currently displayed screen, copying it to a file.  These three
methods of acquiring text are described in this section.

CAPTURING TEXT TO A FILE:
Click on the Capture to File button on the Toolbar, or choose Capture to
File in the Telnet File menu.

If you have not specified a filename to automatically capture the session to,
Telnet will assign one, named CAPTUR##.TXT or CAPTUR##.DAT,
where ## is a number from 00 to 99, and automatically capture to that file.
This number is incremented each time you do a capture.  (When the
CAPTUR99 file is reached, it will restart again with CAPTUR00).

Alternately, you can specify a filename to capture your sessions to (a
“Capture File”) by specifying a Capture File in the <Session> dialog in the
Telnet Settings menu.  If you have a filename selected, you will be asked
each time you capture whether you want to write over that file.  See
“Customizing Telnet Settings” for more information.

There are two ways you can capture text to a file.  You can capture Text
Only, or you can capture Text and Control Characters.  Text Only is the
default; Text and Control Characters will capture everything that comes
from the host, such as control codes, escape codes, line feeds and carriage
returns.  You can choose between these options using Session in the Telnet
Settings menu.

When you start Capture to File, the Capture light on the Status Bar will
turn on, reminding you that everything generated during your session is
being saved to a file.

To end capturing to a file, click again on the Capture to File button on the
Toolbar, or select Capture to File from the File menu (unchecking the
menu option).  The Capture light will turn off, and the capture file will be
closed.

If you want to automatically capture your sessions to a file when you start
Telnet, exit Telnet with the Capture command active, and Save Settings on
Exit chosen.  Your current capture file will be closed, and the next time you
start the same Telnet session, capture will start automatically.

Capturing Telnet Activity to a File or Printer
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CAPTURING TEXT TO A PRINTER:
Click on the Echo button on the Toolbar or choose Echo to Printer in the
Telnet File menu.

All subsequent session text will be printed on the default printer (selected
in Windows).  To print to a different printer, change Print Setup in the
Telnet File menu before printing.

The Print Echo light on the Status Bar will be turned on and will remain
on until you have finished capturing text to the printer.

To end capturing text to the printer, click again on the button on the
Toolbar, or select Echo to Printer from the File menu (unchecking the
menu option).  The Print Echo light will turn off, and text will stop
printing.

If you want to automatically capture your sessions to a printer when you
start Telnet, exit Telnet with the Echo to Printer command active, and
Save Settings on Exit chosen.  The next time you start the same Telnet
session, print capture will start automatically.

CAPTURING THE SCREEN TO A FILE:
Click on the Capture button on the Toolbar or choose Capture Screen
from the Telnet  File menu.

You will see a dialog that will prompt you for a filename for this screen
capture.  The default file ending for this file is .cap.

Type the filename for the screen capture and click OK.  The screen will be
saved to the named file, the file will be closed, and you will return to the
Telnet Console.

The currently displayed screen will be captured to an ASCII file with each
line terminated by a <CR><LF> pair.  This makes it easy to load the image
into a word processor or text editor for inclusion in a document.

If the screen you are capturing contains DEC Special Graphics characters,
they will be translated to their nearest ASCII equivalents before being
written to disk.

Capturing Telnet Activity to a File or Printer
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CUSTOMIZING TELNET SETTINGS
You can customize SPRY Telnet using dialogs in the Telnet Settings menu.
You may never need to change any of these options.  Consult the online
help for information about using these dialogs.

Choose Session to specify settings for the current session, such as the
current login script and capture file.

Figure 6-5

Choose Terminal to set Telnet terminal options, such as terminal emula-
tion and size.  You can map keys on your Telnet keyboard by clicking the
Keyboard button.

Figure 6-6

Customizing Telnet Settings
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Choose Colors to set colors for your Telnet background, text, and bold
text.

Figure 6-7

FONT
Choose Font to change the font, font style and size that Telnet uses to
display text.  Note that only fixed fonts appear in this dialog; Telnet also
includes several VT fonts designed for ease of use with Telnet displays.

Figure 6-8

Customizing Telnet Settings
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USING CUSTOM SESSIONS
Although you can save SPRY Telnet settings at any time by changing them
with the Telnet menus and exiting with Save Settings on Exit, your
changes will affect all Telnet sessions.  If you want to set up different
settings for different Telnet hosts, you will want to create custom sessions.

Custom sessions are especially useful for setting up login scripts that can
automatically log you into your host and start a host application.  You can
also set up different colors, fonts, terminal settings for each custom session.
Basically, any option you can set in the Telnet menus can be set during a
custom session, and those changes will affect only that session.

For instance, you might create a “VI” session for using the VI editor on
your local host that logs you into your host, starts VI, and sets your
preferences for screen colors and fonts.  Or you might create an archie
session that logs you into an archie server, starts archie, and turns ”capture
file” on so that your archie results are automatically dumped to a file.  All
custom sessions are associated directly with a specific host.

When you first start using SPRY Telnet, experiment to find out your
general preferences for colors, fonts, terminal and other settings.  Set Telnet
up with those preferences, and choose Save Settings on Exit; this will save
those settings as your default settings.  Then, when you start creating
Custom Sessions, you can start with those default settings, and then
customize them to suit your needs.

Once you have created a custom Telnet session, you can update the session
settings at any time.

CREATING A CUSTOM SPRY TELNET SESSION:

1) Connect to the host for which you want to create a custom session.

2) Set your Telnet options the way that you would like them for the custom
session, including a custom login script, if desired.

3) Choose Save As Custom Session As from the File menu.  You will be
prompted for the name of a session, and a session description. Type this
information and press [Enter] to create the new session.

After creating a custom Telnet session, you should exit and restart Telnet
before creating another Telnet session.

Using Custom Sessions
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STARTING A CUSTOM SESSION:
You can start custom Telnet sessions from the initial <Open Telnet Session>
dialog.

Type the session name in the Host, IP address or Session Name box and
click OK, or choose the session from the drop down session list.

The Telnet Console will open with the custom session you created.

UPDATING A CUSTOM SESSION:
If you make changes and have Save Settings on Exit checked, the settings
in the session you are using will be updated when you exit SPRY Telnet.

or

Choose Save As Custom Session from the File menu.  You will be
prompted for the name of a session.  Type an existing session name; the
current session will be updated (overwritten) with the current settings, and
your session name will change to the name you specified.

You can change the session description that appears in the <Open Telnet
Session> dialog by choosing Session in the Settings menu and changing
the Description field.

DELETING A CUSTOM SESSION:
If you want to delete a custom session, choose Delete Custom Session in
the Settings menu. You will be asked to specify which session you want to
delete.  Choose the session, and click OK.  The session will be deleted
permanently.

USING TELNET SCRIPTS
SPRY Telnet includes a basic script language which allows you to create
scripts that you can execute to automate repetitive tasks, like logging in or
typing a frequently used sequence of commands.  You can create a script
file from within SPRY Telnet, or use an ASCII text editor like Windows
Notepad to create a script at any time.

See the online help for information on creating and using Telnet login
scripts.

Using Custom Sessions
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